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CHAPTER 1: 990 E-FILE: INTRODUCTION
The IRS has extended e-file capabilities to 990 taxpayers, including the following capabilities:

l accepts calendar and fiscal year returns

l provides taxpayers the option to e-file and pay tax obligations at the same time

l allows taxpayers to file tax returns throughout the year

l uses XML to format return data and transmit to the IRS

l allows binary data (non-XML documents) to be transmitted to the IRS in PDF format

l eliminates drains, processes transmission files, and provided acknowledgment files faster

l uses redesigned Business Rules (diagnostics)

l uses a standardized Acknowledgment File structure across all form types

l uses a Practitioner PIN or scanned Form 8453 for signatures. The IRS will not accept paper Form 8453-EO.

ADVANTAGES TO E-FILE
Tax practice offices can e-file 990/990EZ/990PF/990N income tax returns with the IRS using our 990 application.

While the IRS saves costs with e-filed returns, taxpayers can benefit in the following ways when they e-file their
returns:

l When a return is e-filed, the taxpayer receives an acknowledgment from the IRS of its receipt and
acceptance. This acknowledgment is better than a return receipt from the US Postal Service because the
IRS performs e-file software checks and error checking before accepting a return. The electronic
acknowledgment confirms IRS receipt of a mathematically correct and complete return.

l E-filed returns have fewer errors than paper returns because the e-file process eliminates manual input of
tax return data by IRS employees.

Thomson Reuters is the “electronic transmitter” for Electronic Filing. The tax preparer/firm is the “Electronic
Return Originator” (ERO).

THOMSON REUTERS
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2 Chapter 1: 990 E-file: Introduction

Requirements

REQUIREMENTS
You must have a valid E-file Identification Number (EFIN) to file a return electronically. To receive an EFIN for
your office, Form 8633 MUST be filed with the IRS. If your office had an EFIN last year, it is not necessarily
valid this year (a valid EFIN must have had returns filed under it last year to remain valid). Once
accepted, you do not have to reapply each year as long as you continue to file returns through IRS e-file and are
not suspended from the IRS e-file program.

AUTHORIZATION TO PARTICIPATE IN E-FILE PROGRAM
The IRS Regulations require a preparer to apply for permission to e-file tax returns. To request permission to
participate in thee-file program, file Form 8633, Application to Participate in the IRS E-file Program, with the IRS.

After the application for participation is accepted, the IRS assigns an E-file Identification Number (commonly
referred to as an EFIN) to your firm or office. You will use this EFIN throughout the e-file process.

The IRS-assigned EFIN applies to current and future tax years. You do not have to file Form 8633 each year as
long as you continue to file returns through IRS e-file and are not suspended from the IRS e-file program. If you
filed returns last year through the IRS e-file program, the EFIN continues to be valid for this tax year also.

For more information on the e-file program and filing requirements, please refer to the most current version of the
following documents:

l IRS Pub 4206

l IRS Form 8633

l http://www.irs.gov/efile/index.html

THOMSON REUTERS
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CHAPTER 2: SETTING E-FILE TAX
DEFAULTS

SETTING GENERAL TAX DEFAULTS FOR E-FILE
To set up e-file tax defaults for the entire firm, follow these steps:

1. In Tax Defaults, select E-file > General Information tab.

2. Enter the E-file ID Number (EFIN) for the firm.

Figure 2:1

THOMSON REUTERS
990 E-FILE GUIDE



4 Chapter 2: Setting E-file Tax Defaults

Setting 990 Tax Defaults

3. Select the option, if desired, to allow the IRS to electronically withdraw funds when the return is e-filed with a
balance due.

4. For all return types, indicate if you wish to disable the reminder to recreate e-files (for those returns that
have changed) when you exit the return.

5. Enter text to print on the top of Form 8879 and Form 8453 e-file signature forms before the e-file is qualified.

6. Select the option, if desired, to suppress Form 8948 if the returned is not e-filed and there are no options
selected.

7. (Does not apply to 990) Select the option, if desired not to print the officer’s signature date on the e-file
signature authorization forms for 1065 and 1120. The date will be included in the XML file.

8. Select the option, if desired, to suppress print of the list of PDF attachments included in the e-file return. You
may select this for one, more than one, or all of the listed tax return types.

SETTING 990 TAX DEFAULTS
1. Navigate to E-file > 990.

Figure 2:2

2. Select the type of originator: ERO,Online Filer, Reporting Agent, IRS Agent, Financial Agent, or Large
Taxpayer. The default is None Selected.

THOMSON REUTERS
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Chapter 2: Setting E-file Tax Defaults 5

Setting 990 Tax Defaults

3. Select the default signature method: None Selected, PIN, or Binary Attachment 8453 Signature Document.
You may override this default on a return-by-return basis.

4. If you select the Practitioner PIN, you can select any or all of the following options:

l randomly generate the officer PINs

l use the first five numbers of the Firm Employer ID Number (FEIN) as the ERO PIN.

5. If applicable, select the option to indicate that the ERO is also the paid preparer.

THOMSON REUTERS
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6 Chapter 3: Elections
General Guidelines

CHAPTER 3: ELECTIONS

GENERAL GUIDELINES
The IRS reviewed all forms and form instructions to identify where taxpayers are required to attach supporting
data.Wherever the supporting data is located in an election, the IRS has provided specific XML formats
that must be used.

The IRS has not reviewed all regulations and publications to identify every possible election. Rather than
performing this analysis and then defining specific schemas to match each of these elections, the IRS created a
General Dependency schema.

The General Dependency schema is used for most disclosure statements and elections required by regulations
or IRS publications. The General Dependency schema includes the following elements:

Form Line or Instructions Reference (Optional). Complete this field when the election is made based on
information on IRS forms or form instructions, and the IRS has not defined a specific format.

Regulation Reference (Optional). Use this field to identify information for elections made based on information
contained in regulations or publications.

Description (Optional). Use this field to enter a brief explanation of the election.

Attachment Information (Optional). Use this field to include additional information or to reference PDF
attachments.

The current IRS schema definitions do not support information entered in a columnar format. For elections
requiring columnar format, the IRS allows these to be included in the return as PDF attachments. Separate PDF
files must be created for each election, and the regulation reference should be used in the name of the PDF file.

EXAMPLES OF ELECTION FORMATS
The examples below illustrate how elections can be formatted:

Election Not Containing Columnar Data Election data not containing columnar data must be reported using
the IRS-defined schema for that election. If no schema has been defined, then the General Dependency schema
must be used.

Regulation Reference

IRC §441

THOMSON REUTERS
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Chapter 3: Elections 7
Using the Application

Description

Election to Adopt or Change to a 52-53 Week Tax Year

Attachment Information

Pursuant to IRC §441, taxpayer hereby elects to adopt or change to a 52-53 week tax year beginning with the tax
year ending [date], 2017.

Election That Contains Columnar Data Elections that require columnar data may be attached as PDF files.
Separate PDF files must be created for each election. Use the regulation reference to create the name of the PDF
file.

Elections That Require Supporting Data Some disclosure statements and/or elections require supporting data
that cannot be entered into the General Dependency schema (that is, meeting notes, etc.). The IRS allows this
type of supporting data to be attached to the General Dependency schema as a PDF file. The actual disclosure
statement and/or election must be entered into the required format, and only the supporting data may be
submitted as a PDF file.

USING THE APPLICATION
The application provides several methods for entering federal tax elections. Each method for entering elections
can be completed inOrganizer > Federal Tax Elections.

THOMSON REUTERS
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8 Chapter 3: Elections
Using the Application

Predefined Elections
Many elections are included in the Organizer where you can simply choose those that may be applicable to the
return. These elections are included in the XML file using the General Dependency schema. For example, the
IRC §441 election is found inOrganizer > Federal Tax Elections > Predefined Elections > Code Section
441.

Figure 3:1

THOMSON REUTERS
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Chapter 3: Elections 9
Using the Application

Account-defined Elections
You have the ability to set up your own elections in the Tax Defaults. These elections are displayed within
Organizer > Federal Tax Elections > Account Defined Elections when you open your return. You can then
select those elections that might apply to this return. Modifications can be made to these elections, but Account
Defined elections cannot be added within the return.

Figure 3:2
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10 Chapter 3: Elections
Using the Application

Preparer-defined Elections
You can add your own return-specific elections using the Preparer-Defined Elections screen by entering a new
Short Description. These elections are included in the XML File using the General Dependency schema.

Figure 3:3

For any other elections that are not included in one of the above categories, use Return Footnotes.

THOMSON REUTERS
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Chapter 4: E-filing Returns 11

Steps to E-file Returns

CHAPTER 4: E-FILING RETURNS
Not all returns qualify for e-file. The 990 e-file application generates appropriate diagnostics when it
encounters a return that does not qualify for e-file and rejects the non-qualifying return.

STEPS TO E-FILE RETURNS
1. Prepare the return. See Preparing the Return (page 12).

2. Enable e-file. See Enabling E-file (page 13).

3. Select electronic signature options. See Selecting Electronic Signature Options (page 18).

4. Review attachments, including attaching Form 8453-EO when PIN/Form 8879-EO is not used. See
Reviewing Attachments (page 19).

5. Enter additional information. See Entering Additional Information (page 22).

6. Review e-file diagnostics. See Reviewing E-file Diagnostics (page 24).

7. Create an e-file for the return. See Creating the E-file (page 27).

8. Send qualified returns to the IRS. See Sending Qualified Returns to the IRS (page 29).

9. Verify acknowledgment of receipt by the IRS. See Checking the Status of the E-filed Return (page
31).

10. View rejection notices. See Viewing Rejection Notices (page 33).

THOMSON REUTERS
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12 Chapter 4: E-filing Returns

Preparing the Return

PREPARING THE RETURN

Preparing the Electronic Part of the Return
You must create a data file for every return you wish to e-file. The following major tasks to create a data file are as
follows:

l Enable e-file and auto-calculation.

l Enter PIN or binary signature information.

l Enter any additional information and review PDF attachment details.

l Review the forms list, name control, and special conditions.

l Review e-file diagnostics, including rejects, alerts, and XML validation errors.

l Create an e-file for the return.

Preparing the Paper Part of the Return
Print the tax return. We will generate forms that must be filed with the IRS and forms that are provided to the
taxpayer as a record.

PORTION FILEDWITH THE IRS - FORM 8453-EO

Form 8453-EO: US Individual Income Tax Declaration for Electronic Filing. This form will not print if a
practitioner or self-selected PIN is used.

THOMSON REUTERS
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Enabling E-file

ENABLING E-FILE

THOMSON REUTERS
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14 Chapter 4: E-filing Returns

Enabling E-file

1. On the Organizer tab, select E-file > Return > Enable E-file > Enable E-file.

THOMSON REUTERS
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Chapter 4: E-filing Returns 15

Enabling E-file

Figure 4:1

2. Be sure that Auto-Compute is turned on.

THOMSON REUTERS
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16 Chapter 4: E-filing Returns

Enabling E-file

3. Enter the EFIN (a six-digit number assigned by the Andover IRS service center) and the originator (the ERO
is normally the paid preparer). Both fields are mandatory entries.

4. Select the type of originator: ERO,Online Filer, Reporting Agent, IRS Agent, Financial Agent, or Large
Taxpayer. The default is None selected.

5. Check the box to enable e-file for the federal return. This is a mandatory entry.

6. If desired, select the states for e-file.

Figure 4:2

7. If desired, select the option to suspend the states for e-file.

Figure 4:3

THOMSON REUTERS
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Chapter 4: E-filing Returns 17

Enabling E-file

Deleting the E-file
1. On the Organizer tab, select E-file > Return > Enable E-file > Delete E-file.

Figure 4:4

2. Select the e-file you wish to delete (federal, extension, and/or state e-file).

3. Click the appropriate button.

THOMSON REUTERS
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18 Chapter 4: E-filing Returns

Selecting Electronic Signature Options

SELECTING ELECTRONIC SIGNATURE OPTIONS
1. On the Organizer tab, select E-file > Return > Signature Authorization.

Figure 4:5

2. The taxpayer may select one of two options for signing the return:

l For the Practitioner PIN option, the taxpayer and the ERO will each select a PIN (or use the auto-
generate tax default option), and those numbers will be used to sign the return electronically in the
software. Selecting this option will allow the ERO to complete Form 8879-EO. The EROmust retain
the completed Form 8879-EO for three years.

l If the taxpayer selects the Binary Attachment option, the ERO will complete and print Form 8453-EO.
The ERO will then have all required parties sign the form, scan it into a PDF document, and attach it in
the software as a binary attachment. The name of the PDF file is limited to 23 characters.

3. For the Practitioner PIN, indicate who entered the PIN: ERO or officer.

THOMSON REUTERS
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Chapter 4: E-filing Returns 19

Reviewing Attachments

4. If desired, select the option to randomly generate the officer and ERO PIN.

5. Enter the officer PIN and ERO PIN.

REVIEWING ATTACHMENTS
The most common attachment for a 990 return is the 8453-EO. Form 8453-EO shall be completed and signed by
all required parties and then scanned into a PDF document and inserted into the electronic return as a binary
attachment.

1. Navigate to E-file > Return > Attachments > PDF Attachments > Summary.

Figure 4:6

2. You may add other attachments. For a complete list, please check the Binary Attachment List, located by
clicking the indicated hyperlink on the screen.

For more information on attachments, see Appendix C - Attachments (page 67).

THOMSON REUTERS
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20 Chapter 4: E-filing Returns

Reviewing Attachments

Selecting Binary Attachments for the E-file
1. Navigate to E-file > Return > Attachments > PDF Attachments > Summary.

2. Click the Attach PDF button.

3. In the Attachment Related To field, select Federal. State attachments are not allowed at this time.

4. Browse to select a PDF file.

5. When you select the PDF file, the Description field will automatically show the PDF file name. You cannot
change the TTA Filename field.

6. To delete attachments, select Delete Attachment.

7. When all attachments are added or deleted, selectOK.

8. For informational purposes, you may enter details about the attachments.

9. Return to the e-file process.

Adding General Dependencies
You may add General Dependencies to the e-file as follows:

THOMSON REUTERS
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Chapter 4: E-filing Returns 21

Reviewing Attachments

1. Navigate to E-file > Return > Attachments > General Dependencies > Add General Dependency.

Figure 4:7

2. Enter the form line or instruction reference.

3. Enter the explanation for the general dependency.

THOMSON REUTERS
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22 Chapter 4: E-filing Returns

Entering Additional Information

ENTERING ADDITIONAL INFORMATION

Forms Included in E-file
1. Navigate to E-file > Return > Additional Information > Forms Included in E-file.

Figure 4:8

2. Review the forms to be included in the e-filed return.

THOMSON REUTERS
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Chapter 4: E-filing Returns 23

Entering Additional Information

Business Name Control
1. Navigate to E-file > Return > Additional Information > Business Name Control.

Figure 4:9

2. Review the system-generated business name control.

3. Enter an override for the business name control if the calculated business name does not comply with
Publication 4206 rules. This entry ismandatory. The Name Control field for the corporation is created from
the information specified on the first name line of the corporation name and as per the complete list of rules
specified by IRS Publication 4206. For more information on name control, see Appendix B - Name Control
(page 65).

Special Conditions
1. Select E-file > Return > Additional Information > Special Conditions.

Figure 4:10

2. Enter a description for the special condition.

THOMSON REUTERS
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24 Chapter 4: E-filing Returns

Reviewing E-file Diagnostics

REVIEWING E-FILE DIAGNOSTICS
1. Perform a full recompute of the return.

2. Select View > Diagnostics to open the Diagnostics dialog box. Select the E-file Validation Errors
option.

3. If you have enabled e-file, three folders will exist for e-file diagnostics: Alerts, Rejects, and XML validation
errors.

Types of Diagnostics
Alert Diagnostics: These do not prevent the creation of a qualified e-file. You should still investigate the
conditions causing the Alert diagnostics, as these may reveal input errors.

Reject Diagnostics: These diagnostics identify conditions in the return that will result in an IRS rejection for
failure to meet IRS Business Rules. Reject diagnostics also identify many of the common conditions that may
result in an XML validation error. You must correct the conditions generating a Reject diagnostic before you can
generate a qualified e-file.

XML Validation Errors: Data that does not meet the strict schema formatting requirements of the IRS schemas
result in XML validation errors. This will be indicated by the following message:

Figure 4:11
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Chapter 4: E-filing Returns 25

Reviewing E-file Diagnostics

Reviewing Reject and Alert Diagnostics
1. Expand each folder (E-file - Alerts and E-file - Rejects) to view the text of each diagnostic.

2. Select each diagnostic to go to the source of the diagnostic, and make any necessary changes to prevent
the diagnostic from being regenerated during subsequent tax return computes.

3. Repeat the diagnostic review process for all e-file diagnostics existing on the return.

Some forms cannot be e-filed. When a tax return requires an IRS form that cannot be e-filed,
a corresponding e-file diagnostic is generated.

4. Perform a full recompute on the return, and review any new e-file diagnostics that may have been
generated, modifying input as necessary.

5. Repeat the data modification, compute, and review process until there are no e-file diagnostics listed for the
return.

Reviewing XML Validation Errors
Even though you can view XML validation errors in the View > Diagnostics dialog after you create the e-file, you
will not be able to use theGoTo feature to go to the source of the error. This step describes how to generate an
XML file for validation purposes only. If you generate the XML validation file following these steps, you can use
GoTo to help correct validation errors.

The XML file generated by following these steps will NOT be transmitted to the IRS.

THOMSON REUTERS
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26 Chapter 4: E-filing Returns

Reviewing E-file Diagnostics

1. Select E-file > Return > Error Checking.

2. Click theGenerate Validation File button.

Figure 4:12

3. Select View > Diagnostics, and expand the E-file XML Validation Errors folder to display the XML
validation errors.

4. Depending on the method used to generate the XML file, the validation heading will change. XML validation
errors generated through these steps will have a heading instructing you to useGoTo to correct the error.

Figure 4:13
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Chapter 4: E-filing Returns 27

Creating the E-file

5. Select each validation error to go to the source of the invalid information. This may be a Tax Form field or an
Organizer field. If the error is in a Tax Form field, hyperlink to the applicable Organizer field to correct the
input.

6. The XML validation errors listed in View > Diagnostics will not be updated until you recreate the XML file.

7. After you have corrected all validation errors, create the final XML file to transmit to the IRS.

CREATING THE E-FILE
Follow these steps to create the e-file:

1. If no e-file diagnostics exist, create the file to send to the IRS by clicking the button on the Organizer screen.
A pop-up box appears on the screen confirming that the files were created successfully.

2. Make sure that the file is generated as the last step before sending (after ALL changes have been made to
the return). If not, incorrect information will be sent to the IRS.

THOMSON REUTERS
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28 Chapter 4: E-filing Returns

Creating the E-file

Generating the E-file

1. Navigate to E-file > Return > Create E-File.

Figure 4:14

2. Click the Create Federal E-file button (in area outlined in red).

3. A popup screen will show XML File for Federal Exempt Org. The return is being created.

THOMSON REUTERS
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Sending Qualified Returns to the IRS

4. ClickOK. Another popup screen will show Start XML Validation.

5. ClickOK. If there are no errors, the XML validation is completed. Otherwise, the XML Validation result will
indicate the number of errors.

6. To review the validation errors, select View > Diagnostics > Efile XML Validation Errors, and select
Federal. You will not be able to useGoTo to navigate to these errors.

7. Correct the invalid input causing the errors.

8. Recreate the test file by clicking the button labeledGenerate Federal E-file to clear all validation errors.

9. The application creates an e-file (to be filed with the IRS) only when no e-file diagnostics exist.

10. If the e-file was created without any problem, the application shows a message stating E-files created
successfully.

11. Use the various state buttons to create the files for the e-filed state returns (in areas outlined in green).

SENDING QUALIFIED RETURNS TO THE IRS
Each return that has been determined to beQualified for e-file during the tax return compute process is a
candidate for e-file. The e-file process requires you to select thoseQualified returns that you wish to e-file and
create e-file batches. This batching process initiates a process that sends each locator’s e-file data to the IRS.
Once filed, the IRS will send back an electronic status indicating whether the e-filed return has been Accepted or
Rejected.

In order to batch returns, you must have ELF ADMIN rights. If you do not have them, your firm
administrator may assign these rights to you.

To create an e-file batch, follow the steps below:

1. Select Returns Processing > E-file > Select Returns.

2. Select an Account, Tax Year, and Return Type 990 from the drop-down lists.

3. Select the number of returns to display from the Limit list size to drop-down dialog box.

4. Select the preparer, reviewer,manager, and/or other user group to filter the list, plus any advanced sort
criteria using the Advanced button.

THOMSON REUTERS
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30 Chapter 4: E-filing Returns

Sending Qualified Returns to the IRS

5. Select whether the returns are Federal Ready to Send. Select the e-file type: returns or extensions.

Figure 4:15

6. Click Continue. A list of all returns matching the criteria you selected is created.

7. If you selected Federal Ready to Send:

a. You will see a list of locators with the federal return ready to be sent.

b. You may select which returns you wish to send by checking the box in the Select column.

c. When you select a return, we assume that you want to send all returns that are ready.

8. After you made all your selections, click the Submit for e-file button.

After completing this procedure, your returns will be processed and sent to the IRS.

The processing status of these locators on the E-file Status Report will show as Awaiting Acknowledgment until
the return has either been Accepted or Rejected by the appropriate taxing authority.

THOMSON REUTERS
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Checking the Status of the E-filed Return

CHECKING THE STATUS OF THE E-FILED RETURN

Checking Status in the Locator
Check the e-file status on your return atOrganizer > E-file > Return > Status > Federal.

Figure 4:16

Checking Status in RS Browser
Once the return is e-filed, Thomson Reuters receives an acknowledgment from the IRS that the return was filed.

To view the processing status for all returns (to find out if Thomson Reuters has received the acknowledgment)
perform the following steps:

1. Select Returns Processing > E-file > Status Report.

2. Select an Account, Tax Year, and Return Type 990 from the drop-down lists.

3. Select the number of returns to display from the Limit list size to drop-down dialog box.

4. Select the preparer, reviewer,manager, and/or other user group to filter the list.

5. Select the e-file type: regular, extension, or all e-file types.

THOMSON REUTERS
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32 Chapter 4: E-filing Returns

Checking the Status of the E-filed Return

6. Select the appropriate criteria for federal statuses, and click the Continue button.

Figure 4:17

7. You will see a list of locators that meet the criteria selected on the E-file Status screen.

8. Should the IRS accept the e-filed tax return, the e-file status for the locator will show as Accepted. If this is
the case, the relevant IRS acceptance information appears.

9. Although processing usually occurs within 24 hours, the IRS can take as long as 48 hours to process a
return. If you have not received an acknowledgment of the return within 48 hours, call Thomson Reuters at
1-800-327-8829 to check the status of the return.

THOMSON REUTERS
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Viewing Rejection Notices

VIEWING REJECTION NOTICES
Should the IRS reject the e-filed tax return, the e-file status for the locator will show as Rejected. If this occurs,
follow the steps below:

1. Select Returns Processing > E-file > Status Report.

2. Select the account number, year, and tax type (990).

3. Select the e-file type: return, extension, or all e-file types.

Figure 4:18

4. Select the federal status (in this case, Rejected), and click Continue.

5. On the Batch Report screen, click Rejected (the word Rejected will be a hyperlink) in the Federal Status
column.

6. The appropriate reject messages will appear.

THOMSON REUTERS
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34 Chapter 4: E-filing Returns

Viewing Rejection Notices

7. Select the Print button. (The Rejection Notice will be sent to your default printer.)

8. Review the reason for the rejection as included on the printed Rejection Notice.

If the situation causing the rejection can be corrected:

1. Open the locator and modify the erroneous information.

2. Repeat the process under Preparing the Electronic Part of the Return (page 12) or Preparing the E-
file for the Extension (page 36).

3. Repeat the process of initiating an e-file request.
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The IRS allows e-file of Form 8868. The e-file system:

l uses XML to format return data and transmit to IRS

l eliminates drains, processes transmission files, and provides acknowledgment files faster

l uses redesigned Business Rules (diagnostics)

l uses a standardized Acknowledgment File structure across all form types

l uses a Practitioner PIN for signatures.

E-file provides taxpayers the option to e-file extension and pay tax obligations at the same time and allows
taxpayers to file extension for calendar and fiscal year returns.

In order to e-file a federal extension, you must obtain an EFIN from the IRS by submitting Form 8633. To e-file a
specific state, you must complete required state applications and/or registrations (if any).

Not all extensions qualify for e-file.Our e-file application generates appropriate diagnostics when it
encounters a return that does not qualify for e-file and rejects the non-qualifying return.

LIST OF ACCEPTED FORMS
The following forms and schedules are currently allowed and accepted by the IRS for e-file with Form 8868:

l Form 8868: Extension of Time to File

l Electronic Payment.

STEPS TO E-FILING EXTENSIONS
Go toOrganizer > Extensions and Penalties > Extensions > General Options, and select a print option.

1. Prepare the e-file and paper sections of the extension. See Preparing the Extension (page 36).

2. Enable e-file. See Enabling E-file (page 37).

3. Select signature options. See Selecting Signature Options (page 39).

4. Review additional information. See Reviewing Additional Information (page 42).
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Preparing the Extension

5. Review e-file diagnostics. See Reviewing Extension E-file Diagnostics (page 43).

6. Create an e-file for the extension. See Creating the E-file for the Extension (page 43).

7. Send qualified extensions to the IRS. See Sending Qualified Extensions to the IRS (page 45).

8. Verify acknowledgment of receipt by the IRS and check the status of the e-filed extension. See Checking
the Status of the E-filed Extension (page 47).

9. View rejection notices. See Viewing Rejection Notices (page 49).

PREPARING THE EXTENSION

Preparing the E-file for the Extension
You must create a data file for every locator you wish to e-file. The following major tasks to create a data file are
detailed below:

l Enable e-file and auto-calculation.

l Enter PIN information.

l Enter any additional information.

l Review e-file diagnostics.

l Create an electronic file for the extension.

Preparing the Paper Part of the Extension
Print the extension. We will generate forms that must be filed with the IRS and forms that are provided to the
taxpayer as a record.
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Enabling E-file

ENABLING E-FILE
1. On the Organizer tab, select E-file > Extension > Enable E-file > Enable E-file.

Figure 5:1

2. Enter the EFIN (a six-digit number assigned by the Andover IRS service center).

3. Select the type of originator: ERO,Online Filer, Reporting Agent, IRS Agent, Financial Agent, or Large
Taxpayer. The default is None selected.

4. Check the box to enable e-file for the applicable federal extension (990/990EZ/990PF or 990T).
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Enabling E-file

5. If you wish to suspend an extension, check the box to suspend e-file for the applicable first or second federal
extension.

6. To enable a state extension, select the check box for the applicable state.

Figure 5:2

7. To suspend a state extension, select the check box for the applicable state.

Figure 5:3
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Selecting Signature Options

Deleting the E-file
1. On the Organizer tab, select E-file > Extension > Enable E-file > Delete E-file.

Figure 5:4

2. Select the e-file you wish to delete (federal, first or second extension, and/or state e-file and/or extensions).

3. Click the appropriate button.

SELECTING SIGNATURE OPTIONS
If you are filing the extension with a payment, enter information on the Signature AuthorizationOrganizer.
Signature option details for Form 8868 are applicable only if you have selected the option to allow the IRS to
withdraw funds using the entered bank account information on the Bank InformationOrganizer.
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Selecting Signature Options

1. Navigate to E-file > Extension > Signature Authorization.

Figure 5:5

THOMSON REUTERS
990 E-FILE GUIDE



Chapter 5: E-filing Extensions 41

Selecting Signature Options

2. Select the signature option for 990/990-PF/990-EZ:

l PIN with payment

l 8453-EO-NOT FOR EXTENSION

l Not applicable (without payment).

3. Select the signature option for 990-T:

l PIN with payment

l 8453-EO-NOT FOR EXTENSION

l Not applicable (without payment).

4. Indicate who entered the PIN: Authorized Person (Taxpayer), ERO, or Not applicable.

5. Select the option, if desired, to randomly generate PINs for the officer and ERO.

6. Enter the Officer PIN and ERO PIN. This information is mandatory if it is not entered in Tax Defaults.
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Reviewing Additional Information

REVIEWING ADDITIONAL INFORMATION

Forms Included in the Extension E-file
1. Navigate to E-file > Extension > Additional Information > Forms Included in E-file.

2. Review the forms to be included in the e-file.

Figure 5:6

Reviewing the Business Name Control
1. Navigate to E-file > Extension > Additional Information > Business Name Control.

Figure 5:7

2. Review the system-generated business name control.
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Reviewing Extension E-file Diagnostics

3. Enter an override for the business name control if the calculated business name does not comply with
Publication 4206 rules. This entry ismandatory. The Name Control field for the corporation is created from
the information specified on the first name line of the corporation name and as per the complete list of rules
specified by IRS Publication 4206. For more information on name control, see Appendix B - Name Control
(page 65).

REVIEWING EXTENSION E-FILE DIAGNOSTICS
1. Perform a full recompute of the locator, and make the necessary corrections.

2. Select View > Diagnostics to open the Diagnostics dialog box. Select the E-file option.

3. Review the return information causing the diagnostic, and make any necessary changes to prevent the
diagnostic from being regenerated during subsequent tax return computes.

4. Repeat the diagnostic review process for all e-file diagnostics existing on the locator.

Some forms cannot be e-filed. When an extension requires an IRS form that cannot be e-
filed, a corresponding e-file diagnostic is generated.

5. Perform a full recompute on the locator and review any new e-file diagnostics that may have been
generated, modifying input as necessary. Repeat the data modification, compute, and review process until
there are no e-file diagnostics listed for the locator. The application creates an e-file data file (to be filed with
the IRS) only when no e-file diagnostics exist.

CREATING THE E-FILE FOR THE EXTENSION
Follow these steps to create the e-file:

1. If no e-file diagnostics exist, create the file to send to the IRS by clicking the button on the Organizer screen.
A pop-up box appears on the screen confirming that the files were created successfully.

2. Make sure that the file is generated as the last step before sending (after ALL changes have been made to
the extension). If not, incorrect information will be sent to the IRS.

3. Exit the locator and extension.

THOMSON REUTERS
990 E-FILE GUIDE



44 Chapter 5: E-filing Extensions

Creating the E-file for the Extension

Creating the E-file
1. Go to E-file > Extension > Create E-file.

2. Click the appropriate Create... button on this form (for first or second extension).

3. For 990/990-EZ/990-PF:

Figure 5:8

4. For 990-T:

Figure 5:9
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Sending Qualified Extensions to the IRS

5. For State Extensions:

Figure 5:10

6. If the file was created without any problem, the application shows a message stating E-files created
successfully.

7. Review the XML file information.

This step is also used for reviewing selections for transmission and for disqualifying a previously
qualified return. For further instruction on these functions, press the corresponding button.

SENDING QUALIFIED EXTENSIONS TO THE IRS
Each extension that has been determined to beQualified for e-file during the extension compute process is a
candidate for e-file. The e-file process requires you to select thoseQualified extensions that you wish to e-file and
create e-file batches. This batching process initiates a process that sends each locator’s e-file data to the IRS.
Once filed, the IRS will send back an electronic status indicating whether the e-filed extension has been Accepted
or Rejected.
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Sending Qualified Extensions to the IRS

In order to batch returns, you must have ELF ADMIN rights. If you do not have them, your firm
administrator may assign these rights to you.

To create an e-file batch, follow the steps below:

1. Select Returns Processing > E-file > Select Returns.

2. Select an Account, Tax Year, and Extension Type 990 from the drop-down lists.

3. Select the number of extensions to display from the Limit list size to drop-down dialog box.

4. Select the preparer, reviewer,manager, and/or other user group to filter the list, plus any advanced sort
criteria using the Advanced button.

5. Select First Extension as the return type.

Figure 5:11

6. Select whether the returns are Federal Ready to Send.

7. Click Continue. A list of all extensions matching the criteria you selected is created.
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Checking the Status of the E-filed Extension

8. If you selected Federal Ready to Send:

l You will see a list of locators with the federal return ready to be sent.

l You may select which extensions you wish to send by checking the box in the Select column.

l When you select an extension, we assume that you want to send all extensions that are ready.

l After you made all your selections, click the Submit for e-file button.

9. After completing this procedure, your returns will be processed and sent to the IRS.

10. The processing status of these locators on the E-file Status Report will show as Awaiting Acknowledgment
until the extension has either been Accepted or Rejected by the appropriate taxing authority.

CHECKING THE STATUS OF THE E-FILED EXTENSION
Once the return is e-filed, Thomson Reuters receives an acknowledgment from the IRS that the return was filed.

To view the processing status for all returns (to find out if Thomson Reuters has received the acknowledgment)
perform the following steps:

1. Select Returns Processing > E-file > Status Report.

2. Select an Account, Tax Year, and Return Type 990 from the drop-down lists.

3. Select the number of returns to display from the Limit list size to drop-down dialog box.

4. Select the preparer, reviewer,manager, and/or other user group to filter the list.

5. Select the e-file type: regular, extension, or all e-file types.
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Checking the Status of the E-filed Extension

6. Select the appropriate criteria for federal statuses, and click the Continue button.

Figure 5:12

7. You will see a list of locators that meet the criteria selected on the E-file Status screen.

Should the IRS accept the e-filed tax return, the e-file status for the locator will show as Accepted. If this is the
case, the relevant IRS acceptance information appears.

Although processing usually occurs within 24 hours, the IRS can take as long as 48 hours to process a return. If
you have not received an acknowledgment of the return within 48 hours, call Thomson Reuters at 1-800-327-
8829 to check the status of the return.
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Viewing Rejection Notices

VIEWING REJECTION NOTICES
Should the IRS reject the e-filed tax return, the e-file status for the locator will show as Rejected. If this occurs,
follow the steps below:

1. Select Returns Processing > E-file > Status Report.

2. Select the account number, year, and tax type (990).

3. Select the e-file type: return, extension, or all e-file types.

Figure 5:13

4. Select the federal status (in this case, Rejected), and click Continue.

5. On the Batch Report screen, click Rejected (the word Rejected will be a hyperlink) in the Federal Status
column.

6. The appropriate reject messages will appear.
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Viewing Rejection Notices

7. Select the Print button. (The Rejection Notice will be sent to your default printer.)

8. Review the reason for the rejection as included on the printed Rejection Notice.

If the situation causing the rejection can be corrected:

1. Open the locator and modify the erroneous information.

2. Repeat the process under Preparing the Electronic Part of the Return (page 12) or Preparing the E-
file for the Extension (page 36).

3. Repeat the process of initiating an e-file request.
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CHAPTER 6: AGGREGATING XML FILES
International forms existing in other returns can be merged into the primary return XML file. The other return could
have been prepared using third party software, or could be a GoSystem Tax or ONESOURCE return. All that is
needed is a valid XML file from the other return.

This process aggregates (merges) parts of the third party XML file containing international forms with the primary
return XML file. Other parts of the third party XML file are ignored.

TYPES OF AGGREGATION
l Aggregating International Forms from Returns Created with Third Party Software (page 51)

l Completing the Aggregated Return (page 58)

AGGREGATING INTERNATIONAL FORMS FROM
RETURNS CREATED WITH THIRD PARTY SOFTWARE
To aggregate XML files, attach the XML file of the other return to the primary return.
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Aggregating International Forms from Returns Created with Third Party Software

1. Within the primary return, go toOrganizer > E-file > International > Third Party XML.

Figure 6:1
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Aggregating International Forms from Returns Created with Third Party Software

2. Select the Attach Third Party XML File button on the Third Party XML screen.

Figure 6:2
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Aggregating International Forms from Returns Created with Third Party Software

3. On the Electronic Filing Attachments window, select Add.

Figure 6:3

4. On the Add Attachments dialog box, select Third-Party XML File from the drop-down list, or you can click
Associate Existing to find an existing file.

Figure 6:4
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Aggregating International Forms from Returns Created with Third Party Software

5. Select Browse for File and select the applicable XML file.

Figure 6:5
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Aggregating International Forms from Returns Created with Third Party Software

6. Select Upload to attach the file.

Figure 6:6

7. Repeat this process for each XML file to be included. Select Done when finished.

To delete third party XML files, highlight the attachment on the Electronic Filing
Attachments screen, and then select Delete.

Figure 6:7
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Aggregating International Forms from Returns Created with Third Party Software

8. After attaching all the XML files, confirm that the XML attachment details are correct in the Third Party
Attachments Summary on the Third Party XML screen.

Figure 6:8

The attached XML file names include the locator number of the primary return.

9. The attached XML files must be validated to detect XML errors. Select the Validate Third-Party XML File
button on the Third Party XML screen.

Figure 6:9
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Completing the Aggregated Return

If validation errors exist:

1. Delete the attachment.

2. Use the third-party software to correct the error.

3. Recreate a new XML file.

The aggregation process cannot be completed if any third party XML files contain validation
errors.

COMPLETING THE AGGREGATED RETURN
Step 1: Attach International XIT File. To complete the e-file return:

1. In the Organizer, go to E-file > International > Thomson Reuters International File.

Figure 6:10
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Completing the Aggregated Return

2. Select the Attach Thomson Reuters XIT File button.

Figure 6:11

3. On the resulting Electronic Filing Attachments screen, select Add.

4. On the Add Attachments pop-up dialog box, select International XML File from the drop-down list, and
then select Next.

5. Browse to and select the applicable XIT file.

6. On the Electronic Filing Attachments screen, select Done.

7. Repeat this process for each XIT file to be included.

8. After attaching the XIT files, confirm that the XIT attachment details are correct in the International
Aggregation section at the bottom of the screen.

The attached XIT file names include the locator number of the primary return.
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Completing the Aggregated Return

Step 2. Create Aggregated E-file. This step combines the International XIT files into the XML file of the primary
return.

On the E-file > Create E-file screen, click the Create Federal E-file 990/990EZ/990PF button.

Figure 6:12

In all cases, be sure to review the E-file Viewer to confirm the international forms are included in
the complete XML file as expected.
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Appendix A - Accepted Forms and Schedules

CHAPTER 6: APPENDICES

APPENDIX A - ACCEPTED FORMS AND SCHEDULES
The following lists are forms and schedules currently allowed and accepted by the IRS for e-file with 990 returns.

Forms and Schedules for E-file
The forms and schedules listed at the following URL are the only forms and schedules acceptable for e-file. The
E-file Notes lists the number of forms allowable by the IRS.

https://www.riahelp.com/html/2023/reports/ef_forms/990/990_Federal_E-file_Forms.pdf

This document is kept current.

Form 990: Other Forms and Schedules for E-file
l Affiliate Listing Detail Statement

l Affiliated Group Attachment

l Affiliated Group Schedule

l Averaging Attachment

l Reasonable Cause Explanation
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Appendix A - Accepted Forms and Schedules

Form 990EZ: Other Forms and Schedules for E-file
l Affiliated Group Attachment

l Affiliated Group Schedule

l Averaging Attachment

l Explanation of Non UBI

l Reasonable Cause Explanation

l General Explanation

l Grants and Other Similar Amounts Paid Schedule

l Other Assets Schedule

l Other Expenses Schedule

l Other Liabilities Schedule

l Other Revenues Schedule

l Transfers Personal Benefits Contracts Declaration

Form 990PF: Other Forms and Schedules for E-file
l Part I, line 6: Gain/Loss from Sale of Other Assets

l Part I, line 10: Sales of Inventory Schedule

l Part I, line 11: Other Income

l Part I, line 16(a): Legal Fees

l Part I, line 16(b): Accounting Fees

l Part I, line 16(c): Other Professional Fees

l Part I, line 18: Taxes

l Part I, line 19: Depreciation

l Part I, line 23: Amortization
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l Part I, line 23: Other Expenses

l Part II, line 6: Other Receivables from Officers

l Part II, line 7: Other Notes/Loans Receivable Long

l Part II, line 7: Other Notes/Loans Receivable Short 2

l Part II, line 10(a): Investment Government Obligations

l Part II, line 10(b): Investment Corporate Stock

l Part II, line 10(c): Investment Corporate Bonds

l Part II, line 11: Investments Land

l Part II, line 13: Investments Other

l Part II, line 14: Land, Etc.

l Part II, line 15: Other Assets

l Part II, line 20: Loans from Officers

l Part II, line 21: Mortgages and Notes Payable

l Part II, line 22: Other Liabilities

l Part III, line 3: Other Increases

l Part III, line 5: Other Decreases

l Part VI, line 2: Tax Under Section 511

l Part VII, line 2: Activity Not Previously Report

l Part VII, line 8: Explanation of Nonfiling with AG

l Part VII-A, line 10: Substantial Contributors

l Part VII-A, line 11a: Transfer from Controlled Entity

l Part VII-A, line 11a: Transfer to Controlled Entity

l Part VII-B, line 2: Section 4942(a) Explanation
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l Part VII-B, line 5: Expenditure Responsibility

l Part VIII, line 1: Compensation Explanation

l Part VIII, line 2: Employee Compensation

l Part VIII, line 3: Contractor Compensation

l Part IX-B, line 3: All Other Program Related Investments

l Part X, line 1: Reduction Explanation

l Part X, line 4: Cash Deemed Charitable

l Part XII, line 1: Borrowed Funds Election

l Part XII, line 3: Cash Distribution Explanation

l Part XIII, line 4(b): Applied to Prior Year Election

l Part XIII, line 4(c): Distribution from Corpus Election

l Electronic Payment for 990-PF

l General Explanation Attachment

l Reasonable Cause Explanation

BINARY ATTACHMENTS
l Form 8453-EO: Exempt Organization Declaration and Signature for Electronic Filing

Form 8868: Other Forms and Schedules for E-file
l Electronic Payment
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APPENDIX B - NAME CONTROL

Using Name Control
The Name Control field for the corporation is created from the information specified on the first name line of the
corporation name and as per the complete list of rules specified by the IRS.

The system automatically generates the Business Name Control. You may override the Business Name Control if
the calculation does not comply with Pub. 4206 rules.

To review the Business Name Control, navigate to E-file > Return > Additional Information > Business
Name Control.

Figure 6:13

Name Control Rules
Use the following name control rules to prepare the exempt organization return/extension:

NAME CONTROL GENERAL INFORMATION

1. The Name Control consists of up to four alphanumeric characters.

2. The Name Control should be determined from the information specified on the first name line. Generally, the
Name Control is derived from the first four characters of the organization’s legal name.

3. The ampersand (&) and hyphen (-) are the only special characters allowed in the Name Control.
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4. The Name Control can have less, but no more than, four characters. Blanks may be present only at the end
of the Name Control.

5. Do not included dba (doing business as) as part of the Name Control.

NAME CONTROL VALID CHARACTERS
l Numeric (0-9)

l Alpha (A-Z)

l Hyphen (-)

l Ampersand (&)

NAME CONTROL SPECIAL RULE

If an invalid character is used in the name line, drop the special character from the organization’s name. For
example, for 4U.com, the Name Control should be 4UCO.

Examples of Name Control

BASIC NAME CONTROL RULE (CALCULATED)

ORGANIZATION’S NAME NAME CONTROL

Sumac Field Plow Inc SUMA

11th Street Inc. 11TH

P & P Company P&PC

Y-Z Drive Co Y-ZD

ZZZ Club ZZZC

Palm Catalpa Ltd PALM

Fir Homeowners Assn. FIRH
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NAME CONTROL RULE REGARDING “THE”

ORGANIZATION’S NAME NAME CONTROL

TheWillow Co. Will

The Hawthorn THEN

NAME CONTROL RULE REGARDING “PC,” “SC,” “PA,” OR “PS”

ORGANIZATION’S NAME NAME CONTROL

The Joseph Holly Fund JOSE

The Joseph Holly Foundation JOSE

Kathryn Fir Memorial Fdn. KATH

NAME CONTROL RULE REGARDING “FRATERNAL ORGANIZATIONS”

ORGANIZATION’S NAME NAME CONTROL

City of Fort Hickory Board CITY

Walnut County Employees Association WALN

Rhode Alpha Chapter Alpha Tau Fraternity RHOA

House Assn. of Beta XI Chapter of Omicron Delta Kappa HOUS

APPENDIX C - ATTACHMENTS
Taxpayers are instructed to attach supporting information to the tax return. This includes tax forms, statements,
elections, notices, schedules, or other types of miscellaneous information that may be required by IRS form
instructions, regulations, or publications. These attachments may be submitted electronically as XML files or as
PDF files.
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XML Files
The IRS has defined schemas for the following information which must be provided in XML format:

l Tax Forms. We automatically format tax form information included in the return as XML.

l Information requested on tax form instructions to support specific lines, such as “Other Income.” In some
cases, the schema provides specific data elements; in other cases, the schema allows for entry of free-form
text. We automatically format this additional information included in the return as XML.

l Information requested in regulations or publications which is not specified in form instructions but which
must still be included in XML format. The IRS has defined two schemas for this information:

o Elections

o All other information not specifically requested.

l If information for either of these two schemas requires presentation in a columnar format, the IRS will allow
this information to be submitted as a PDF attachment.

PDF Files
PDF file types are the only files allowed as non-XML attachments by the IRS.

Keep PDF attachments as small as possible. If you are using Adobe Acrobat, avoid requiring compatibility with
Adobe Acrobat versions earlier than version 6. Making the PDF file compatible with earlier versions will increase
the size of the file. Move the compression/quality slider on the Create PDF from Scanner to higher compression
to decrease the size of the file when the source document is of decent quality and comes from scanner input.

Each individual uncompressed PDF cannot exceed 60 MB. The total of all uncompressed PDF files in the return
cannot exceed one GB.

Multiple PDF files may be submitted, but each PDF file must be smaller than 60 MB.

If you are filing any of the IRS forms allowed as a PDF attachment, you must create a separate file for each form
type included as a PDF (that is, one file for Forms 926, one file for Forms 982, and so forth).

The file name of each PDF cannot exceed 64 characters, which includes the locator number and the file
extension (12 characters), and cannot contain any of the special characters shown below.
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The title for attachments is limited to 128 characters and must be meaningful. The IRS relies on meaningful titles
for referencing the correct attachments. The IRS has predefined the title for four types of attachments. These
predefined titles are:

l 8453-EO Signature Document

l Changes not reported to IRS.

Forbidden Characters in PDF Filenames

The filename cannot contain any of the following characters:

l Apostrophe (')

l Double quotation mark (")

l Left and right angle brackets (<) and (>)

l Vertical bar (|)

l Square brackets ([ ])

l Caret (^)

l Ampersand (&(the and symbol above the number 7 on the keyboard))

l Slashes (/) and (\)

l Colon and semicolon (:) and (;)

l Question and exclamation marks (?) and (!)

l Asterisk (*)

l Double periods (..)

Steps for Attaching PDF Files
Follow these steps for attaching PDF files:

1. To display the Electronic Filing Attachments window, go toOrganizer > E-file > Return > Attachments
> PDF Attachments > Summary.

2. Select the Attach PDF button.
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3. In the E-file Attachments window, click Add to add a new attachment.

4. On the Add Attachment window, select the jurisdiction (or form) for which this attachment should apply.

5. The next window allows you to browse to the desired PDF file. Select the PDF file, and click Next.

6. The next window will indicate the selected file. You must now select a meaningful title for the attachment.
You can select one of the predefined titles, or enter your own user-defined title. The default user-defined title
is the file name without the extension. After selecting one of the predefined titles, or entering your own
meaningful title, click Next.

7. The selected PDF file now appears on the E-file Attachments window and shows the jurisdiction,
attachment title, file name, file size, and date modified. Click Done to complete the attachment.

8. Review the PDF attachments included in the return on the Attachments Organizer screen.

Meaningful Titles
Meaningful titles must be described in 128 characters or less. The following are examples of meaningful titles:

PDF ATTACHMENT DESCRIPTION PDF FILE NAME EXAMPLES

A warehousing leasing agreement required by regulations Leasing Agmt

An appraiser statement on a Francisco de Goya oil painting Appraiser Stmt

An appraiser statement on a Pablo Picasso painting Picasso A Appraiser

An appraiser statement for a second Pablo Picasso painting Picasso B Appraiser

THOMSON REUTERS
990 E-FILE GUIDE



Chapter 6: Appendices 71

Appendix D - Frequently Asked Questions

Options Available for PDF Attachments
Once you have attached a PDF, you have several additional options. From the E-file Attachments window, you
may associate an existing attachment with additional jurisdictions, replace or delete an attachment, or retrieve an
attachment.

To associate an existing attachment with other jurisdictions:

1. Click Add.

2. Select the attachment jurisdiction.

3. Click Associate an existing attachment with an additional jurisdiction.

4. Click Next. The Attach Existing File screen lists the file names of the original attachment, preceded by the
original jurisdiction.

5. ClickOK, and then edit the title if necessary.

6. Click Finish.

At this time, the federal return, the federal extension, and California are the only forms and jurisdictions that allow
PDF attachments.

To retrieve or download an attachment:

1. Highlight the desired attachment.

2. Click Retrieve.

3. Follow the on-screen instructions for saving the file.

APPENDIX D - FREQUENTLY ASKED QUESTIONS

Attachments
Can we attach Word documents or cut/paste text into the tax return?

You may cut and paste into our free form text boxes (General Explanation Statement); however, the formatting
will be stripped during the creation of the XML file.
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Can we attach a PDF from any PDF-generating program?

Yes. However, the file name is limited to 23 characters.

Can the 990 tax app translate PDFs or receive electronic information provided by brokerage houses?
Can we bridge this information into the tax app from Excel or other software?

If the files are Excel files (or other spreadsheet files that can be converted to .DIF files), then the best option for
inclusion in the return is Data Connection. This avoids problems with trapped data.

Can we attach or bridge Excel files?

Yes. This will be accomplished through DIF import.

How much text space is available for each question?

Descriptions throughout the return are generally unlimited in length (some exceptions apply).

Will any free form text be allowed?

Yes. The IRS will allow an XML attachment called the General Explanation Statement. The IRS currently allows
ten (10) of these statements. For each statement, we have provided a text area that allows approximately ten (10)
pages of data entry (approximately 100,000 characters).

Since the IRS does not accept PDFs, how do we attach 500 pages of purchase and sales securities and
investments information received in hard copy?

As Thomson Reuters provides data entry fields for purchase and sale securities, clients should enter the data
properly through the provided fields. DIF import and Data Connection will help in the transfer of bulk information.

Data Entry
Will some data entry be required of all users?

Due to IRS requirements, address fields that were previously rolled from one year to the next via proforma will
need to be entered in a new field. For example, several fields exists with the City, State, Zip in a single field. You
will need to re- enter this information in three separate fields.
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Diagnostics
How do I clear the following e-file reject diagnostic: 990 E-FILE: If Form 990, Part VII, line 1A check box
(immediately above the table) is not checked, then one complete entry must present in Form 990, Part
VII, Section A, line 1A (include Name, title, average hours per week, position, and compensation)?

1. Go to Tax Forms > Federal > 990 > 990 > 990, page 7.

2. Verify that at least one employee listed has an amount, or NONE, displayed in Columns D, E, and F.

3. If one of these columns is blank, navigate in Organizer to Form 990 > Form 990 > Pt VII - Compensation
of Officers/Directors > Officers, Directors, Trustees, Employees > Employee Name.

4. Enter NONE in the applicable field to populate this column for one employee.

Due Dates
Can 990 returns be e-filed after October 15?

Yes. You can e-file three years of returns (two prior years, plus current year) all year round.

Extensions
How do we attach the extension, or is it automatic?

Extensions cannot be attached to the 990 return in e-file. If an extension was previously e-filed or paper filed, the
IRS does not allow/require a copy of the extension to be sent electronically with the return.

Can extensions be attached to the 990 return?

No, extensions cannot be attached to the 990 return in the electronic format.

Overrides
How do overrides work in the system?

Data sent via XML will be taken from the tax form side of the software. Therefore, overrides will be transmitted.
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CAUTION should be used, since an incorrect override may trigger IRS business rules (i.e., diagnostics) and
cause the return to reject.

Can we print N/A in the current version of Form 990?

N/A is not a valid response in XML. Either yes, no, or a blank will be transmitted.

PINs
How do I automatically generate taxpayer and ERO PINs for e-file?

For 990 returns, this option must be selected in Tax Defaults, under E-file > 990.

Rejections
How do I resolve the following e-file rejection:

Type FED
Record Name IRS990 Form Occurrence No. 0 Field Sequence No. 0 Form No. F990
Form Page No. 1 Reject Code 153
Extended Reject Code 0
Error Message If Form 990, Part VII, Line 1a checkbox (immediately above the table) is not checked,
then at least one complete entry must be present in Form 990, Part VII, Section A, Line 1a.
XPath to Error /efile:Return/efile:ReturnData/efile:IRS990 Error Category Missing Data
Rule Number F990-153 Severity Reject
Data Value Missing CompensationFromRelatedOrganization Data Reject Message:

There are two possible solutions to this rejection:

1. Go to Tax Forms > Federal > Form 990 > 990, page 7.

2. Ensure that there is something (either a dollar amount or NONE) in Columns D, E, and F, for at least one of
the employees listed.

OR

1. Go toOrganizer > Form 990 > Form 990 > Pt VII - Compensation of Officers/Directors > Officers,
Directors, Trustees, Employees > Employee Name.
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2. Ensure that the Average hours per week devoted to position have been entered for at least one
employee.

Error when e-file return more than three years old: I am trying to e-file a return from four years ago, and
the return is being rejected with a message similar to the following: The return type (specified in the
Return Header) and the return version (specified by the return Version attribute of the Return element)
of the return must match the return type and the version supported by the Modernized E-file system.
How do I resolve this error?

The IRS Business MeF system only supports e-files on a rolling basis that includes the current and two prior tax
years. When transmitting an e-file in the current tax year, the MeF system will process only that year and the two
preceding years.

If you have any questions regarding this IRS e-file rejection, please contact the IRS e-Help Desk at 1-866-255-
0654.

Schedule B
Will Schedule B be marked Not Open for Public Inspection?

For the printed disclosure copy, Form 990 will print with Copy for Public Inspection, and Schedule B will print
without the Contributors names and addresses. For e-filed returns, this information is required.

Signature Requirements
How does the preparer sign the return? How does the client sign the return? Must clients get a PIN?
How do we use Form 8879-EO and/or Form 8453-EO?

The taxpayer may select one of two options for signing the return:

l If the taxpayer selects the PIN option, the taxpayer and the ERO will each select a PIN, and those numbers
will be used to sign the return electronically in the software. Selecting this option will allow the ERO to
complete Form 8879- EO. The EROmust retain the completed Form 8879-EO for three years.

l If the taxpayer selects the Binary Attachment option, the ERO will complete and print Form 8453-EO.
Subsequently, the ERO will have all required parties sign the Form and will then scan it into a PDF
document and attach it in the software as a binary attachment. The name of the PDF file is limited to 23
characters.
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l The taxpayer may bypass Forms 8879-EO and 8453-EO if the taxpayer is e-filing Extension Form 8868 and
no payment is due.

Size Limitation
Is there a size limitation for files transmitted?

No, neither Thomson Reuters nor the IRS anticipates that any client’s return will be too large for the system to
handle.

Viewing Completed Returns
Will we receive or be able to print a final "filed copy"?

Yes.

How will we preview a completed return before filing?

Clients should still review their returns via print and print preview.

XML Validation Errors
Resolving XML Validation Errors

How do I resolve the following e-file rejection? Type FED
Record Name IRS990 Form Occurrence No. 0 Field Sequence No. 0 Form No. F990
Form Page No. 1 Reject Code 153
Extended Reject Code 0
Error Message If Form 990, Part VII, Line 1a checkbox (immediately above the table) is not checked,
then at least one complete entry must be present in Form 990, Part VII, Section A, Line 1a.
XPath to Error /efile:Return/efile:ReturnData/efile:IRS990 Error Category Missing Data
Rule Number F990-153 Severity Reject
Data Value Missing CompensationFromRelatedOrganization Data Reject Message:

To correct this XML Validation error:
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1. Go toOrganizer > Form 990 > Form 990 > Part III - Program Services > Program Services.

2. Under the Program Service Activity #1 section, enter information in the Description field.
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