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Introduction and conversion overview 

The Engagement Manager™ Conversion wizard is available by request and enables batch conversions of 
multiple clients from Creative Solutions Accounting™ (CSA). This conversion guide covers the steps 
required to import the data files and explains where imported data appears within Engagement 
Manager. 

Please review this document in its entirety before beginning the conversion process for either single or 
multiple clients. 

Objective 
The overall objective is to provide a conversion of client data from Trial Balance CS® and Engagement 
CS® in CSA to Engagement Manager. However, due to differences in processing calculations and data 
structures between CSA and Engagement Manager, some data cannot be imported. Therefore, you 
should not expect to exactly duplicate results from CSA using the imported data without adding or 
modifying the appropriate data in Engagement Manager. Items that you cannot import and conversion 
exceptions are listed in the “Data not transferred” section, starting on page 10 of this guide. 

 

 

 

 



 

 

 

Conversion considerations and recommendations 
 

Please review the following considerations and recommendations before beginning the conversion 
process and when preparing to import converted data into Engagement Manager. 

 

General information 
▪ We recommend that you import a smaller, easy-to-process client first. This will help you to become 

familiar with the conversion options in Engagement Manager. 

▪ Some data items from CSA are not imported because there is no exact equivalent in Engagement 

Manager. 

▪ In cases where data items within Engagement Manager do not exist within CSA, we will enter 
the default values in Engagement Manager. 

▪ The conversion program imports wrapped-up engagements from Engagement CS as finalized 
engagements in Engagement Manager. 

▪ The integration between Engagement Manager, Microsoft® Word, and Microsoft Excel® is designed 

for specific versions of Microsoft products. While the integration features may operate properly with 
other versions of Microsoft Office applications, the results may not be desirable. Please note that the 
conversion program supports only the following versions of Microsoft Office, and that these 
requirements apply to each workstation on which you run the conversion program. 

▪ Microsoft Office 2007 

▪ Microsoft Office 2010 

▪ Microsoft Office 2013 

 

Configuring the logging process for separate sessions 
Follow these steps to have the conversion application automatically create a separate log file for each 
conversion session. 

1. On the workstation that you will using to run the conversion, navigate to 
C:\Users\<user name>\AppData\Roaming\AdvanceFlow\Conversion. 

 
2. Right-click and choose New > Text Document from the context menu. 

 
3. Rename the new file to “log.txt” and press ENTER. 

 
The conversion application will now automatically create a log.txt file in the 

C:\Users\<user name>\AppData\Roaming\AdvanceFlow\Conversion folder each time you run the 
conversion process. The resulting log files can provide useful information if you need to troubleshoot any 
conversion issues. 

  



 

 

Preparing the client data 
Follow these steps in CSA and in Engagement Manager before converting client data. 

 

Pre-conversion steps in CSA 

▪ Open the Chart of Accounts window in CSA, choose Edit > Verify Accounts, and fix any issues. 

▪ Compact your client data before importing. From the CSA main window, choose Help > Repair. In the 
Repair dialog, select the client that you will import and then click the Compact button. 

▪ If you are converting client data from Engagement CS, restore any archived engagements that you 

would like to convert for the client by choosing File > Archive > Restore in Engagement CS. 
 

Note: We recommend that you keep wrapped up and archived engagements in Engagement CS in 
addition to keeping a static electronic copy. Because of the difference between the two products, 
some data may not convert completely, and keeping historic data in Engagement CS ensures data 
integrity. 

 

▪ If the option to compress/secure engagement data is marked in the Help > Repair dialog in CSA, 
clear that option and then open and close each client prior to converting. 

 

Pre-import steps in Engagement Manager 

▪ Review the security settings in Engagement Manager and GoFileRoom that are related to import and 
conversion processes. 

▪ Create staff logins for all users that exist in Creative Solutions Accounting. You will need to map the 
staff during the conversion process. 

 

Installing the conversion program 
 

Copy the “Engagement Manager conversion Setup.msi” file to your local machine and double-click the file 
to install the Engagement Manager conversion program to C:\Program Files (x86)\Thomson 
Reuters\EngagementManager. 

 

Important! If you encounter errors during the conversion, verify with your administrator that you have 
read, write, and modify access to the following areas. 

▪ C:\Users\<user>\AppData\Local\Temp 

▪ C:\Users\<user>\AppData\Roaming\AdvanceFlow 
 

 
Preliminary steps for Virtual Office CS 
If you’re running Engagement CS through Virtual Office CS, the conversion application won’t be able to 

process your firm’s hosted data. Therefore, you must follow these steps before running the conversion 
application. 

1. Install Engagement CS to a local workstation or network server. 

 

2. Back up your client and system data from Virtual Office. 

 
3. Restore the client and system data to the workstation on which you installed Engagement CS. 



 

 

For more information on backing up client and system data in Creative Solutions Accounting, choose 
Help > Help & How-To from within CSA and search on Backup and restore. 

 

Import procedure 
 

Follow these steps to import CSA client data into Engagement Manager using the conversion wizard. 

1. Run the Engagement Manager Conversion.exe file to start the conversion wizard. 

 
2. Enter the system and client data paths for Creative Solutions Accounting. 

 
3. Enter your Engagement Manager credentials and click Log In. 

 
4. Map an existing CSA staff member to an existing Engagement Manager user and click Next. 

 

Note: If there is not an equivalent Engagement Manager user, leave the field blank. 
 

5. Select the client or clients whose engagements you would like to convert and click Next. 

 
6. Click the engagement name button next to each client to select the engagements you would like to 

convert. Select the engagement type for each engagement that you would like to convert. Click Next 
once you are done selecting engagements. 

 

Note: If you do not select an engagement, the conversion program will convert only Trial Balance 
data and will place the data in an engagement entitled “Trial Balance” for the selected client. 

 

7. Map the existing CSA client to the corresponding clients in Engagement Manager and then click Next. 

 
8. Select the CSA grouping schedule that will be used to map to the Engagement Manager Account 

Classification account grouping. Then, map the CSA grouping code and subcode to the 
corresponding Account Classification code and subcode. Click Next when the mapping is complete. 

 

Note: The Account Classification is used to assign the account type in Engagement Manager. If an 
account is not mapped to an account classification code and subcode, the account will not be 
assigned an account type. The type can be assigned at a later time. For more information, see 
Assigning account types in the Help & How-To Center. 

 

9. Click OK to begin the conversion process. The conversion time is dependent on the size of the CSA 
client and the number of Excel and Word documents that contain formulas. 

 

Note: During the conversion of some Microsoft Word or Excel Workpapers from Engagement CS, the 
conversion program may prompt you to save changes to a temporary file. If so, click No to continue with 
the conversion. You may also see messages about the Microsoft Office Excel – Compatibility Checker. If 
you do, click Continue to proceed with the conversion process. 

 

 

Data transferred during conversion 
 

The following tables provide details about CSA data that is converted to Engagement Manager. The tables 
are organized by CSA and Engagement Manager screens and specify the necessary screen navigation. 

 

http://cs.thomsonreuters.com/ua/advflow/cs_us_en/trial_balance/assigning-account-types.htm?Product=advflw&mybanner=1
http://cs.thomsonreuters.com/ua/advflow/cs_us_en/trial_balance/assigning-account-types.htm?Product=advflw&mybanner=1


 

 

Balance definitions 
 

CSA menu navigation 
and field name 

Engagement Manager menu 
navigation and field name 

Comments and additional 
information 

Setup > Balance Definitions Trial Balance tab > Balance 
Definitions 

Customized balance definitions 
are not converted. The default 
balance definitions will be used. 

Adjusted Adjusted  

Report Report  

Tax Federal Tax  

Other Other  

 

 
Chart of Accounts and balances 

 

CSA menu navigation 
and field name 

Engagement Manager menu 
navigation and field name 

Comments and additional 
information 

Setup > Chart of Accounts Trial Balance tab 

Mask  The conversion program will 
convert the L or D character in 
the mask as divisions in 
Engagement Manager. If the 
mask contains both L and D 
characters, only the L characters 
will be converted as divisions. 

Acct # Account number  

Type Classification code 

Classification subcode 

The Type in CSA corresponds 
with the Classification code in 
Engagement Manager. For 
example, Classification codes 
CA, NPE, and NCA are asset 
codes, while codes CL and LTL 
are liability codes. 

CSA account groups are 
automatically mapped to 
Engagement Manager 
Classification codes when a 
match can be made. 

The Classification Subcode 
further defines the account based 
on the selected Classification 
code. 

Description Description  



 

 

CSA menu navigation 
and field name 

Engagement Manager menu 
navigation and field name 

Comments and additional 
information 

Tax Code Tax Code Tax codes and tax code 
assignments are imported only 
for clients with a year end of 
2012 or later. UltraTax CS tax 
codes are converted by default. 
If your firm uses GoSystem® Tax 
RS, see “Verifying your 
converted data” on page 13. 

 Property Code For a multi-unit client, the unit 
number is not appended to the 
tax code in Engagement 
Manager. 

Budget Budget  

Adjusted Budget Adjusted Budget  

Setup > Chart of Accounts > 
Enter Combining Accounts 

 Combining accounts are not 
imported into Engagement 
Manager. 

Setup > Chart of Accounts > 
Edit Schedule M-3 Tax Codes 

Trial Balance tab 

M-3 Tax Code M-3 Code Custom M-3 tax codes convert to 
custom tax codes in Engagement 
Manager. 

Setup > Chart of Accounts > 
Tax Code Account Groupings 

  

Description   

Tax Code Tax Code Not converted. 

<Account # to Account #>   

Setup > Chart of Accounts > 
Schedule M-3 Tax Code 
Account Groupings 

Trial Balance tab 

Description   

M-3 Tax Code M-3 Tax Code  

<Account # to Account #> M-3 Tax Code Not converted. 

 



 

 

Grouping schedules 
 

CSA menu navigation 
and field name 

Engagement Manager menu 
navigation and field name 

Comments and additional 
information 

Setup > Grouping Schedules Trial Balance tab > Account Groupings 

Description Description  

Code > Description Code > Description  

Subcode > Description Subcode > Description  

 

 
Transactions 

 

CSA menu navigation 
and field name 

Engagement Manager menu 
navigation and field name 

Comments and additional 
information 

Tasks > Transaction Entry Journal Entries tab 

Journal  Not converted. 

Tasks > Transaction Entry > 
Journal Entries tab 
OR 

Tasks > Adjusting Journal 
Entries 

Journal Entry tab 

Reference Reference  

Date  Not converted. 

Description Description  

Workpaper Workpaper Reference Workpaper references are 
imported for the journal entry. If 
the option to enter multiple 
descriptions and workpaper 
references was enabled in Trial 
Balance CS, only the main 
description and reference are 
converted. 

Additional Distributions (Account, 
Amount, Description) 

Distributions (Account, 
Description, Amount) 

 

Special Types Roll Forward  

Regular Exclude  

Reversing Reverse  

Recurring Include  

Recurring Template Zero balances  

Prior  Journal entries are posted to the 
specific engagement for which 
they were intended. 



 

 

CSA menu navigation 
and field name 

Engagement Manager menu 
navigation and field name 

Comments and additional 
information 

Adjusting Adjusting  

Tax Adjustment Federal Tax  

Reclassifying Reclassifying  

Other Other  

Potential Proposed  

 
 

 

Engagement-related data transferred during conversion 
 

The following information is provided to identify Engagement CS items that automatically convert to 
Engagement Manager. 

 

Engagement information 
 

CSA menu navigation 
and field name 

Engagement Manager menu 
navigation and field name 

Comments and additional 
information 

File > Engagement Properties Engagement Properties 

Name Engagement name  

 Status  

Engagement period ending date Periods tab > Current Period  

Begin date Dates tab > Beginning  

End date Ending  

Audit engagement Type  

Public entity Type  

Report release date Report release  

View > Tree View Window Workpapers tab  

Engagement tree structure Engagement tree structure  

 

 
Folder information 

 

CSA menu navigation 
and field name 

Engagement Manager menu 
navigation and field name 

Comments and additional 
information 

Tree View window Engagement tree structure 

Folder name Folder name  



 

 

Notes 
 

CSA menu navigation 
and field name 

Engagement Manager menu 
navigation and field name 

Comments and additional 
information 

Edit > Edit Review Note Notes List 

Subject Subject  

Dialog and Note text Note  

Cleared Status  

Reviewed   

 

 
Workpaper information 

CSA menu navigation 
and field name 

Engagement Manager menu 
navigation and field name 

Comments and additional 
information 

Edit > Workpaper Properties Workpaper Properties 

Workpaper name Description  

Workpaper Reference Reference  

Assigned to User Assignment  

Roll Forward Roll Forward  

Delete during Wrap Up Delete during finalize  

 

 
Workpaper signoffs 

 

CSA menu navigation 
and field name 

Engagement Manager menu 
navigation and field name 

Comments and additional 
information 

Edit > Workpaper Properties > 
Signoffs 

Workpaper Properties > Sign offs tab 

Name Staff Name  

Signoff Signoff Type  

Date Date  



 

 

Engagement CS Excel and Word balance links (formulas / field 
functions) 
The following table lists the applicable Engagement CS formulas and the equivalent formula variables in 
Engagement Manager. 

 

Engagement CS variable type Comments and additional information 

Account Converts to variable type Amount or Text and to variable source 
Account. 

Account Groups Does not convert; there is no equivalent formula in Engagement 
Manager. 

Additional Amounts Does not convert; there is no equivalent formula in Engagement 
Manager. 

Cash Flow Lines Does not convert; there is no equivalent formula in Engagement 
Manager. 

Date Converts to variable type Text and as Period End Date variables 
under the variable source Engagement Properties. 

Grouping Schedule Converts to variable type Amount or Text and to variable source 
Account Grouping. 

Net Income Variable Converts to variable type Amount and to variable source Net Income 
Calculation. 

Text Converts to variable type Text and to the equivalent variable source 

Workpaper Properties Converts to variable type Text and to variable source Workpaper 
Properties. 

Balance type: Potential JE Converts to Proposed JE 

Balance type: Tax Converts to Federal Tax 

Period: [CP] Converts to CY 

 
 

Data not transferred from Trial Balance CS 
 

Although most data is imported from CSA, some data and setup information cannot be imported due to 
differences in features and data structures between CSA and Engagement Manager. Following the 
conversion, you will need to set up this information, if applicable, in Engagement Manager. 

 

Rounding setup information 
As of the 9.0 release of Engagement Manager, rounding features are available. The conversion program 

won’t convert CSA rounding setup information but it will convert the rounding journal entry created by 
CSA. If you would like to enable the rounding feature, we recommend that you convert as usual, roll 
forward, and then enable the rounding option in the new engagement from within Engagement Manager. 



 

 

Trial Balance 
Verify that classification codes and subcodes are correct for each account. 

▪ Tax codes and tax code assignments are not imported for any client with a year-end date earlier than 
2012. 

▪ Workpaper References entered into the Trial Balance grid are not imported. 

 

Client information 
Entity type is the only client information converted. 

 

Consolidated Clients 
The trial balance is not converted for consolidated clients. However, the workpapers for the consolidated 
client are converted into an Engagement Manager engagement. 

 

Financial Statements 
Financial statements created using the Financial Reporter module are not included in the conversion to 
Engagement Manager. 

 

Signoff Types 
You must set up signoff types in Engagement Manager prior to the conversion. Choose Administration > 
Signoff Types. 

 

Staff 
Staff members that you set up in CSA are not included in the conversion to Engagement Manager. 

 

Staff security settings 
Security settings are not included in the conversion. To set up security in Engagement Manager, choose 
Administration > Roles. 

 

Transactions 
Budget journal entries are not imported. You can enter budget balances directly within the Trial Balance 
screen. Adjusted budget amounts are imported into the adjusted budget balance. 

The conversion program does not import tax code entries at this time. Tax code assignments are not 
imported for any client with a year-end date earlier than 2012.Data not transferred from Engagement CS 

 

Archived engagements 
The conversion program does not import archived engagements. To include archived engagements, 
restore them in CSA prior to starting the conversion. 



 

 

Engagement binder properties 
Engagement staff assignments, engagement staff privileges, and engagement descriptions are not 
imported. 

 

History 
Engagement binder and workpaper history are not imported. 

 

Local client data 
Engagement binders designated as local client data (LCD) are not imported. Check all workpapers back 
in to the master client data (MCD) prior to the conversion process. 

 

Microsoft Excel formulas 
Additional amount and text variables are not converted. 

Engagement CS formulas for location/department clients created using the location/department filter are 
converted, but no location/department (segment) selection will be included in the formula. Microsoft Excel 
workpapers may include formulas that cannot be converted due to there being no equivalent formulas 
available in Engagement Manager. Those that cannot be converted include formulas for account groups 
and cash- flow lines. When these workpapers are opened in Engagement Manager, the original 
Engagement CS formula will be included and may be displayed as #NAME. 

Variables or formulas that contain simple Excel functions, such as ROUND, will be converted. More 

complex functions, such as CONCATENATE, will not be converted. This includes functions that contain 
variables in multiple parameters. 

Microsoft Excel workpapers in a finalized engagement may display formulas as #VALUE!. To display the 
correct formula values, unfinalize the engagement after the conversion process, open and save the Excel 
workpapers, and then finalize the engagement again. 

 

Microsoft Word formulas 
Additional amount and text variables are not converted. 

Microsoft Word workpapers that are imported may include add-ins, macros or links. Therefore, when 
these workpapers are opened in Engagement Manager, variables may be displayed as #VALUE or 
#NAME. 

Links to other workpapers are not converted. 

Microsoft Word workpapers in a finalized engagement may display formulas as blank or with an error. To 
display the correct formula values, unfinalize the engagement after converting, open and save the Word 
workpapers, and then finalize the engagement again. 

 

Signoffs 
The signoff is updated to match the Engagement Manager signoff initials that were mapped during the 
conversion. Signoffs added at the engagement level are not imported. Signoffs added for a signoff type 
that has been deleted are not imported. 

 

Workpapers 
The conversion program will truncate to 25 characters any references that are longer than 25 characters. 

 
 



 

 

Wrapped-up engagements 
Wrapped-up engagements are imported as finalized engagements. Workpapers included in the finalized 
engagements will have a locked status. Locked workpapers will open in read-only mode and any formulas 
in those workpapers will not recalculate. 

As noted above, Microsoft Excel workpapers in a finalized engagement may display formulas as 
#VALUE!. To display the correct formula values, unfinalize the engagement after the conversion, open 
and save the Excel workpapers, and then finalize the engagement again. 

 

Verifying your converted data 
 

Although the conversion program is designed to import your data as accurately as possible, there are 

some instances when the conversion program may not import all data correctly due to data corruption or 
other anomalies in the CSA data. Use the following steps, as well as any information from the diagnostics 
you printed earlier in the conversion process, to verify that your client data has been imported correctly. 

1. In CSA, open the client database and print the following reports: 

 
▪ Adjusting Journal Entry Report 

▪ Trial Balance 

2. In Engagement Manager, view the trial balance. 

 
3. Compare the reports from CSA with the trial balance and reports from Engagement Manager. If the 

information contained in the CSA reports does not match the Engagement Manager trial balance and 
reports, you will need to determine which items are invalid or missing and manually enter them in 
Engagement Manager. 

 

Note: If your firm uses GoSystem Tax RS, right-click the name of any unfinalized engagement and 
select Properties to change the tax vendor from UltraTax CS to GoSystem Tax. 

 

 
Tax codes 
If you use a tax application other than UltraTax CS®, you will have to select the appropriate tax vendor in 
the Engagement Properties > General tab after the conversion to ensure proper mapping. 

 
 

If you encounter problems 
 

If you encounter problems while importing client data from CSA to Engagement Manager but are unable to 
reconcile the data using the various reports and tools in CSA, please consult the following resources. 

 

Help & How-To Center 
For answers to questions on using Engagement Manager, access the Help & How-To Center by clicking 
the Help link on the toolbar.  To find out more about the available resources visit this article.  

  

 

https://www.thomsonreuters.com/en-us/help/engagement-manager/get-help/resources.html


 

 

Product support 
From the Support Contact Information page on our website, you can complete a form to send a question 
to our Support team. For additional details (including extended support hours for tax season and hours for 
other applications), visit the Support section of our website. You can also access the Support section from 
within Engagement Manager by choosing Help > Additional Resources > General Support 
Information. 

 

Website resources and email subscriptions 
Visit our website to access the Tax & Accounting Community, to learn about training courses, to view 
blogs and articles, and more. You can access the website from within Engagement Manager by 
choosing Help > On the Web > CS Professional Suite Home page. 

We issue Engagement Manager update notices via email. You can sign up to receive these notices by 
visiting the Your Accounts section of our website. You’ll need to create a web account (if you don’t already 
have one) and then sign up for the Email Subscription service where you can indicate which notices you 
want to receive. 

 

https://tax.thomsonreuters.com/us/en/cs-professional-suite/support/contact#contact
https://tax.thomsonreuters.com/en/support
http://tax.thomsonreuters.com/
https://tax.thomsonreuters.com/your-accounts
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