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Overview 
The examples in this document explain how preparers can use the UltraTax CS Data Mining feature to 
complete the following tasks. 

 Design a custom report that lists the dates of birth for all 1040 clients. 

 Generate reports that highlight invoice information for all 1040 clients. 

 Identify 1040 clients who are eligible for estimated tax payments and generate a letter that details the 
amounts to be paid. 

 Identify clients who need to participate in an insurance exchange to continue their tax savings under 
the Credit for Small Employer Health Insurance Premiums (Form 8941). 

Creating a birthday report 
You can use Data Mining to generate reports based on the information you enter in UltraTax CS. For 
example, a birthday report could include each client’s ID number, name, and date of birth. After you 
generate a birthday report, you can use Data Mining to generate mailing labels for each of the clients 
listed in the report. 

Note: Custom reports, letters, and searches can be proforma’d from the prior year version of UltraTax 
CS. To do so, choose Utilities > Proforma and select Data Mining from the drop-down list in the top left 
corner. Move the documents you want to proforma to the right pane, and then click the Proforma button. 

$
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Designing a custom report 
The following example shows how to design a custom report that includes each UltraTax CS client’s ID 
number, name, and date of birth. 

1. In UltraTax CS, choose Utilities > Data Mining to open the main Data Mining window. 

Note: The Data location drop-down list is available in the Data Mining window. More than one person 
can access the same data location at the same time, but only one person can search an entity at one 
time. 

2. In the Data Mining window, select the UltraTax CS database in which to search. For this example, 
select 1040 Individual from the Client database drop-down list, and then click the Continue (Step 2) 
button. 

3. Click the Design Custom Reports button to open the Custom Reports dialog. 

4. Click Add to open the Add Custom Report dialog.  

Note: You can create new reports that are based on existing templates. To do so, select a template 
from the Template drop-down list. 

5. Enter Birthday Report in the Description field, and click Continue to open the Custom Report Layout 
dialog. 

 

Add CustomReport H

Enter the new report description and optionally a pre-existing report
template. Clicking Continue will lead you through a series of screens
to complete the customreport.

Description: BirthdayReport

Iemplate:

Continue... Cancel
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6. Highlight Client ID in the Name list, and click Select to move the item to the Columns in layout pane. 

7. Highlight Client name, and click Select. 

 

Note: To change the order in which items appear in the report, highlight an item in the Columns in 
layout pane, and click either Move Up or Move Down. You can see an example of the report 
presentation in the Preview group box at the bottom of the Custom Report Layout dialog. 

8. Select Federal from the Product drop-down list. 

Custom Report Layout

Report name:Birthday Report

Presentation
Product:General
 Calculated yalue
 Input screen field Select Field.. Columns in layout:

Name Total ProductName Move Up
Client Addr Full Slip US Client ID MoveDown
Client Addr FullSlip (sentence style) US  Client name
Client Address Full  Field length:
Client Address Full(sentence style) 40

Client TIN 
Client name (first last)
Client status
Complexity factor
Contact address 1
Contact address 2
Contact apt number

Select -> <·Bemove

Preview
Font size: (Porrait)

ClientID Clientname
 Sample Text  Sample Text

Ascending Primary column:  Subtotal Descending
Ascending Secondary column: Descending OK Cancel
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9. Click the Input screen field option, and then click the Select Field button. The Input Screen Field 
Selection dialog opens. 

10. In Screen 1040 (in the General folder), scroll to the Taxpayer Information section, and click the Date 
of birth field. 

 
11. Click Select to return to the Custom Report Layout dialog. Notice that the 1040, Tp date of birth item 

appears in the Columns in layout pane. 

12. Click OK to finish the custom report. 

13. Click Done to close the Custom Reports dialog. The Print Selection and Client Search dialog opens. 

Now that you designed a custom report, you can use the report to perform a search. 

Performing a search 
The following example shows how to perform a search in Data Mining to generate a birthday report that 
includes all 1040 clients. The criteria used in the search are based on the items that you selected when 
you designed the Birthday Report, as described in the previous section. 

1. In the Print Selection and Client Search dialog, with the Reports option selected, highlight Birthday 
Report in the Available to print pane, and then click Select. 

Input Screen Field Selection

1040 ContactBank Info 1310 8332 2120US IDTheft8379 ComPStLetter Consent

General Taxpayer Information Spouse Information
Nonresident Alien
Electronic Filing
Payments SSN
Income First name
Retirenent
Business Last name
Rent & Royalty Occupation
Farm
Farm Rental Presidential election campaign fund (1=Yes.2=No.3=Blonk.wcp reminder)
K1 1065. 1120S Dependent of another
K1 1041
Personal Sale Meets certain children age18 through 23conditionsÿ1=Yes.2=No)
Foreign Bank & Asse1 First time filing taxreturn
Foreign Exclusion
1040 Adjustments Childneitherparentisalive(Under18orful-timestudent between19ond 23)
Educate Blind
Itemized Deductions
Health Care Date of birth(mm/ddl)
Taxes Date of death
Credits
Accounting Change Daytime telephone/ext number
Other With Return
Separate Filings Home/evening telephone number
5 471 Authorize discussion with IRS(1=Yes.2=No)
8588
Carrvovers Bona fide residentofUSpossession

Did you know... Select Cancel
Tp date of death
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2. In the Client search/focus group box, select All clients from the Search name drop-down list, and then 
click the Continue (Step 3) button. 

 
3. If one or more clients pass the search, the Print dialog opens. Note that all clients that returned 

positive search results are marked in the Selected to print pane. To view Results by Client and 
Search Criteria, click the Search Results button. 

4. For purposes of this example, click Preview to view the report. 

5. Click Close to exit the Preview window. The main Print dialog opens. 

6. Click Cancel to close the Print dialog. The main Data Mining window opens. 

Note: To export the most recent search results, choose Tools > Export Report from the main Data 
Mining window, choose the clients to include in the report, click Continue, and then select the desired 
export options in the Export dialog. 

Now that you generated a report, you can create mailing labels based on the search results. 

Print Selection and Client Search: 1040 Individual

Step 2: Set up print selection and client search. Restore Last Selection
Clear All Selections

 Print selection
Available to print:  37Selected to print:

Reports CS Client Return Summary Birthday Report Design Custom Reports.
 Mailing labels CS Client Forms Prepared Compose Client Letters..
 Export reportCS Firm Return Summary

CS Preparer Return Summary
CS Client Contact Information
CS Client Invoice Information
View Sample.. Select -> <-Remove

Client search/focus
 Product:Federal

Search name:Allclients Add/Modify Searches...
Criteria:US: 1040, Tp last name between Blank and zz

Focus:None selected Additional Focus....

Did you know... Bac... Continue [Step 3]. Cancel
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Generating mailing labels 
The following example shows how to generate mailing labels for each of the clients listed in the birthday 
report. 

Note: You can complete a search specifically to create mailing labels. To do so, click the Mailing labels 
option in the Print Selection and Client Search dialog before performing a search. 

1. In the main Data Mining window, verify that 1040 Individual is selected in the Client database drop-
down list. 

Note: The default client database is the same client database that was used in the most recent 
search. 

2. Choose Tools > Mailing Labels to open the Mailing Labels dialog. Note that the clients that are listed 
in the birthday report are also listed in the Clients selected pane.  
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3. Click Continue. Use the Print Data Mining Mailing Labels dialog to select the desired printer and label 
settings. For this example, use the default settings.  

4. Click Preview to view the mailing labels.  

 
5. For purposes of this example, click Close to exit the Preview window. 

You have generated a birthday report and mailing labels for clients who passed the search. 

Creating an invoice information report 
You can use Data Mining to generate invoice information reports that include each client’s gross invoice 
amount, invoice payment total, net invoice amount, and other criteria. You must enter invoice-related 
data, which includes per-form pricing, per-return pricing, and invoice payments, in UltraTax CS before you 
can generate a report. 

Note: You can generate invoice information reports for all entities available within UltraTax CS. 

Entering invoice information in UltraTax CS 
The following example shows how to enter various types of invoice-related data. You can enter per-form 
prices that are applicable to all 1040 clients or to a specific client, as well as enter a per-return price that 
is client-specific. You can also enter invoice payments and user-defined invoice items.  

Note: If you want to include sales tax in all 1040-client invoices, in UltraTax CS, choose Setup > 1040 
Individual, click the Invoice button, select Text & Format Options from the drop-down list, click the Options 
button, enter a sales-tax percentage in the Sales tax rate field, and then click OK. 
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Pricing per form 
Prices entered on a per-form basis are applied to all 1040 clients. 

1. In UltraTax CS, choose Setup > 1040 Individual. 

2. In the 1040 Product Information dialog, click the Invoice button, and select Pricing from the drop-
down list. 

3. In the Invoice Pricing dialog, mark the checkbox next to each form for which you want to assign a 
price, and then enter an amount in the corresponding Form Price field. If applicable, enter an amount 
in the Item Price field.  

 
4. Click Done to close the Invoice Pricing dialog. 

5. Click OK to close the 1040 Product Information dialog. 

The form pricing will apply to all 1040 clients. However, UltraTax CS provides a way to bill one particular 
client on a per-return basis, as detailed in the next section. 

Invoice Pricing ÿ

Find what: Find 

Form Form Price Item Price
Form 14039 (ldentity Theft Affidavit)

Form 9465 (Installment Agreement Request)
Form 433-F (Collection Information Stmt)

Form \W-7 (Application for ITIN)
Form 1040 (lndividual Income Tax Return) 150.00
Form 1040A (lndividual Income Tax Return)

Form 1040-EZ (Ilndividual Income Tax Return)
Form 1040NR (Nonresident Alien Tax Return)

Form 1040NR-EZ (Nonresident Alien Tax Return)
Form 1040-SS (US Self-Employment Tax Return)
Form 1040-PR (US Self-Employment Tax Return)
Form 1040X (Amended Individual Tax Return)
Form 2210 (Underpayment of Estimated Tax)
Form 2210F (Underpayment of Estimated Tax)
Form 2210 Penalty Worksheet
Schedule A (ltemized Deductions)
Schedule B (lnterest and Dividend Income)

Mark All Increase Al.. Print Done

 
 

 

   
 

 
 

 
  

 
 

 
 
 

 
 

 
 

 
 

 

   



UltraTax CS: Data Mining Examples TL 38137 
Copyright 1991 – 2018 by Thomson Reuters. All rights reserved. Page 9 

Pricing per return 
Prices entered on a per-return basis are applied to specific 1040 clients. 

1. In UltraTax CS, open a client’s return to charge on a per-return basis. 

2. Click the Letter tab in the General folder. 

3. In the Invoices section, enter 450 in the Invoice Amount (Force) field. This amount should be the 
gross invoice amount before additional invoice items, prior payments received, discounts, or taxes. 
Any amount entered in this field overrides pricing-per-form amounts.  

 

Note: If a client is proforma’d from the previous year, the gross amount of the previous year’s invoice 
displays in the Prior year gross invoice amount field. If an amount is present when you generate an 
invoice information report, the amount displays as a line item in the report. 

Invoices
Custom invoice number (Replaces 1040 default invoice)
Include prior year tax preparation fee from invoice on Schedule A (After discounts and before sales tax)
Prior year gross invoice amount (Before prior payments received, discounts, or sales tax)

450.00
Additional invoice items
Prior payments received
Apply a discount of dollars OR percent to invoice:

Dollar discount
Percent discount (xx.x)

New referral Referred by
Client invoice number
Suppress client invoice printing

Miscellaneous Variables and Mailing Slipsheet
Miscellaneous variables can be entered into transmittal letters, filing instructions, or invoices

Miscellaneous text variable #1
Miscellaneous text variable #2
Miscellaneous amount variable #1
Miscellaneous amount variable #2
Attention (If mailing address different from Scren 1040)
Slipsheet name (Force)
Slipsheet address and apartment (Force)
Slipsheet city, state, zip code (Force)
Slipsheet foreign country code/name (Force)
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4. Open the statement dialog for the Additional invoice items field to enter additional user-defined, 
billable items. In this example, travel fees in the amount of $25.00 were incurred and are billable.  

 

5. Click the Open Statement Tab  button and select Prior Payments Received from the drop-down 
list. In this example, two prior payments of $75 were received. 

 

Additional Invoice Items ÿ X

StatementEdit Column Help

S- Done

Additional Invoiceltems

Additional Invoice Items Amount
Do Not

Description Proforma
Travelfees 25.00

ÿ Click here to add new item.

25.00

Travel fees

S-

StatementsFrom Letter X

Statement P3 Column Help

Done

Additional Invoice ItemsPrior Payments Received

Description Date Amount

January Payment for 2014 Tax Return1/05/14 75.00

2 February Payment for 2014 Tax Returm 2/04/14 75.00

16

150.00
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6. Click Done to close the statement dialogs. Note that UltraTax CS automatically adds the amounts and 
enters the total in the Prior payments received field.  

 
7. Right-click and choose View/Customize Invoice from the context menu. Previewing the invoice 

calculates the invoice and ensures that the invoice totals include all invoice-related information. 

8. Click Close to exit the preview window. The Custom Invoice Amounts dialog opens. 

9. In this example, prices for specific forms do not need to be entered or modified because a flat fee is 
charged for the return rather than billing the client for each form. Click Done to close the Custom 
Invoice Amounts dialog. 

Note: When you create an invoice for a specific client, you can include a list of all forms used in the 
return even when the client is billed on a per-return basis. To do this, choose Setup > 1040 Individual, 
click the Invoice button, select Text & Format Options from the drop-down list, click the Options 
button, and mark the List all forms billed for checkbox in the Invoice Options dialog. Then, open the 
desired client, choose View > View/Customize Invoice from the main UltraTax CS menu, click Close 
to exit the preview window, and then click the Mark All button in the Custom Invoice Amounts dialog 
to mark all forms. 

Now that you entered per-return-pricing information in UltraTax CS, you can generate an invoice 
information report in Data Mining. 

Generating an invoice information report 
You can use Data Mining to generate an invoice information report based on the information you entered 
in UltraTax CS. An invoice information report is based on a predefined template that is included with Data 
Mining. The following example shows how to perform a search in Data Mining that retrieves invoice-
related data for all 1040 clients in UltraTax CS and displays the results in a report. 

1. In UltraTax CS, choose Utilities > Data Mining. 

Invoices
Custom invoice number (Replaces 1040 default invoice)
Include prior year tax preparation fee from invoice on Schedule A (After discounts and before sales tax)
Prior year gross invoice amount (Before prior payments received, discounts, or sales tax)
Invoice amount (Force) (Before additional invoice items, prior payments received, discounts, or sales tax)450.00
Additional invoice items S 25.00
Prior payments received 150.00
Apply a discount of dollars OR percent to invoice:

Dollar discount
Percent discount (xxxx)

New referral Referred by
Client invoice number

Suppress client invoice printing

Miscellaneous Variables and Mailing Slipsheet
Miscellaneous variables can be entered into transmittal letters, filing instructions, or invoices

Miscellaneous text variable #1
Miscellaneous text variable #2

Miscellaneous amount variable #1
Miscellaneous amount variable #2
Attention (If mailing address different from Screen 1040)
Slipsheet name (Force)
Slipsheet address and apartment (Force)
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2. In the Data Mining window, select 1040 Individual from the Client database drop-down list, and click 
the Continue (Step 2) button to open the Print Selection and Client Search dialog. 

3. Highlight the CS Client Invoice Information report in the Print Selection pane, and click Select. 

 
4. Select All Clients from the Search name drop-down list in the Client search/focus group box, and click 

the Continue (Step 3) button to perform the search. 

Print Selection and Client Search: 1040 Individual

Step 2: Set up print selection and client search Restore Last Selection
Clear All Selections

 Print selection
Available to print:  37Selected to print:

Reports CS Client Return Summary CS Client Invoice Information Design Custom Reports..
 Mailing labels CS Client Forms Prepared Compose Client Letters..
 Export reportCS Firm Return Summary

CS Preparer Return Summary
CS Client Contact Information
CS 1040 Client and Dependent Information

View Sample.. Select -> <-Remove
Client search/focus

 Product:Federal

Search name:Allclients Add/Modify Searches....
Criteria:US: 1040, Tp last name between Blank and zz

Focus:None selected Additional Focus....

Did you know... Bac... Continue [Step 3]..Cancel
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5. After the search is complete, Data Mining reacts in one of two ways. 

 If no clients passed the search, the Search Results dialog automatically opens. 

 If one or more clients passed the search, the Print dialog opens where you can print letters and 
reports, send letters to clients via email, or view the search results (if necessary) by clicking the 
Search Results button. 

6. After you review the search results, click Preview to view the CS Client Invoice Information report. 

7. Click Close to exit the preview window. 

Creating an estimated tax payment letter 
You can use Data Mining to identify 1040 clients who are eligible for estimated tax payments and to 
generate a letter that details the amounts to be paid. Taxpayers may be required to make estimated tax 
payments if the taxpayer expects to owe more than a certain amount, as specified by the Internal 
Revenue Service. Performing this search in Data Mining automatically identifies which clients are eligible 
and produces a standardized letter that you can customize for your clients and either print or send via 
email. 

Searching for clients subject to estimated tax payments 
The following example shows how to perform a search in Data Mining, which includes selecting search 
criteria and choosing the format in which results are displayed. 

1. In UltraTax CS, choose Utilities > Data Mining to open the main Data Mining window. 

2. In the Data Mining window, select the UltraTax CS database in which to search. For this example, 
select 1040 Individual from the Client database drop-down list, and then click the Continue (Step 2) 
button. 
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3. In the Print Selection and Client Search dialog, select Letters from the drop-down list in the Print 
selection group box, highlight the Estimate Reminder 1st Quarter letter, and click Select. 

 
4. Select Form 1040-ES clients – 1st quarter estimate from the Search name drop-down list in the Client 

search/focus group box. 

5. Click the Continue (Step 3) button to perform the search.  

6. After the search is complete, Data Mining reacts in one of two ways. 

 If no clients passed the search, the Search Results dialog automatically opens. 

 If one or more clients passed the search, the Print dialog opens where you can print letters and 
reports, send letters to clients via email, or view the search results (if necessary) by clicking the 
Search Results button. 

Notes 

 From the Print dialog, you can send the estimated tax payments letter via email to any client with 
an email address that is marked in the Selected to print pane. To do so, mark the Electronic 
delivery checkbox and then select the Email client letters… option in the Print where group box, 
enter a subject in the Subject of email field, and then click the Email / Print button. 

 You can enter email information in several locations: (1) in Data Mining, choose Setup > Email 
Addresses, (2) in UltraTax CS, open Screen Contact in the General folder, and (3) in UltraTax 
CS, choose Setup > Client Communications. 

7. Click Preview to view the estimated payment reminder letter. 

Print Selection and Client Search: 1040 Individual

Step 2: Set up print selection and client search Restore Last Selection
Clear All Selections

 Print selection
Available to print:42 Selected to print: 1

Letters Tax Planning Letter Estimate Reminder 1st Quarter Design Custom Reports..
 Mailing labels Appointment Reminder Compose Client Letters..
 Export reportAppointment Reminder - Next Vear

Estimate Reminder 2nd Quarter
Estimate Reminder 3rd Quarter
Estimate Reminder 4th Quarter

Select -> <-Remove
Client search/focus

 Product:Federal [(Recommended)
Search name:Form 1040-ES clients - 1st quarter estimate Add/Modify Searches.

Criteria:US: 1040-ES, Estimate Amount 1 for DM > 0 Combine federal/state
OR (AL: 40ES, 1st Estimate Payment > 0 AND AL: 40ES, Payment1 for EFW = 0)  Show criteria detail
ORAR: AR1000ES, 1st Estimate Payment > 0
OR AZ: 140ES, 1st Estimate Payment > 0
OR CA: 540-ES, 1st Estimate Payment > 0
ORCO:104-EP, 1st Estimate Payment > 0

Focus:None selected Additional Focus....

"mouy nof p! Back.. Continue [Step 3]..Cancel
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Note: To print the letter from the preview window, click the Print Page  or Print All  button. 
When you close the preview window, the main Data Mining window opens. 

Modifying a letter 
Data Mining offers several predefined letters from which to choose; however, you may need to customize 
an existing letter. Modifying a letter in Data Mining’s Document Editing window is similar to modifying a 
letter in any other word-processing application. You can enter and delete text, change font attributes, 
insert images, modify the layout of the page, and make numerous other modifications. However, a 
primary advantage of creating and editing Data Mining letters is the ability to insert variables that pull 
specific information from UltraTax CS. 

The following example shows how to modify an existing letter to include estimated tax payment amounts 
for all four quarters. 

1. In UltraTax CS, choose Utilities > Data Mining to open the main Data Mining window. 

2. Choose Setup > Compose Client Letters to open the Data Mining Letters dialog. 

Note: You can also click the Compose Client Letters button in the Print Selection and Client Search 
dialog to open the Data Mining Letters dialog. 

3. With Federal selected from the Product drop-down list, highlight the Estimate Reminder 1st Quarter 
letter and click Open to edit the letter in the Document Editing window. 

 
4. Press CTRL+A to highlight all the text in the letter and then choose Edit > Copy to copy the text. 

Data Mining Letters ÿ X

Letters

Product:Federal New

Description Edited Open
Individual Engagement Letter
Individual Engagement Letter - Next Year Properties.
Individual Extension Letter Delete
Client Demographic Information
Tax Planning Letter
Appointment Reminder
Appointment Reminder - Next Year

Estimate Reminder 1st Quarter

EstimateReminder 2nd Quarter
Estimate Reminder 3rd Quarter

EstimateReminder4thQuarter
Direct Debit Reminder

Options. Close
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5. Choose Document > New. 

6. Enter Estimate Reminder 4 Quarters in the Document name field, and click OK. 

7. Place your cursor at the end of the text in this document and press and hold BACKSPACE until all of 
the text is gone. Then, choose Edit > Paste to paste the text from the Estimate Reminder 1st Quarter 
letter into the new document. 

8. Notice the first paragraph in the Federal Estimate section. The segments of red text in brackets are 
Data Mining variables that relate to specific information within UltraTax CS. When this letter is printed, 
this paragraph will show the due date and estimated payment amount for the first quarter. 

 
In the following steps, we’ll add paragraphs for the 2nd, 3rd, and 4th quarter due dates and estimated 
tax payment amounts, using the first one as a guide. 

9. Press ENTER twice and enter Your second on a line beneath the “Your first…” paragraph. Note that 
you should enter a space after the word “second” to provide proper spacing between the word and 
the variable to be inserted in the following step. 

10. Choose Insert > Variable to open the Variables dialog. 

Yourfirst[US:Taxyear-next]federal estimated taxpayment of S[US:1040-ES,Estimate
Amount 1 for DM] is due on[US: Date due for 1040-ESEstimate 1(full text)]

You may use any of the following options to make the federal estimated tax payment:

Check -Make the check payable to the United States Treasury.Write your social security
number and "[US: Tax year - next] Form 1040-ES" on the check. Mail to [US: Estimate
addressbefore]

Credit orDebit Card-Click on Credit or Debit Card atwww.irs.gov/e-pay forthe list of
IRS e-pay service providers and associated convenience fees. You may be able to deduct
convenience fees paid on next year's taxes so be sure to store the amount with your [US: Tax
year-next]taxinformation.

Electronic finds transfer or phone -Enroll in the ElectronicFederal Tax Payment System?
(EFTPS)to pay electronically or via phone. There is no charge for usimg EFTPS. Contact
EFTPS for payment information by calling1-800-555-4477(Customer Service)or accessing
www.eftps.gov.

EndIfUS:Form1040-ES check-1st quarterestimate}
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11. Click the Text option, and highlight the Tax year – next variable in the Variable Name list.  

 
12. Click OK to insert the highlighted variable into the letter. 

13. Press SPACE and enter federal estimated tax payment of $, and enter a space. 

14. Choose Insert > Variable. 

15. From the Variables dialog, verify that the Amount option is selected. 

16. Scroll through the Variable Name list, and highlight 1040-ES, Estimate Amount 2 for DM. 

 
17. Click OK to insert the variable into the letter and enter a space. 

Variables ÿ

Variables

Product:Federal

Amount OText  Date Input screen Select field

Variable Name

Staff office
States
Tax delivery method
Tax delivery method PY
Tax year
Tax year - next
Taxpayer age - 1/1/NY
Taxpayer age - 12/31/yy (tax year)
Taxpayer age - today
Time appt - next
Time appt - prior

OK Cancel

Variables ÿ

Variables

Product:Federal

Amount Text  Date Input screen Select field

Variable Name

1040-ES, 1st quarter estimate Paid flag
1040-ES, 1st quarter estimate reported in Filing Instructions
1040-ES, 2nd quarter estimate Paid flag
1040-ES, 2nd quarter estimate reported in Filing Instructions

1040-ES, 3rd quarter estimate Paid flag
1040-ES, 3rd quarter estimate reported in Filing Instructions
1040-ES, 4th quarter estimate Paid flag
1040-ES, 4th quarter estimate reported in Filing Instructions
1040-ES, Estimate Amount1 for DM
1040-ES, Estimate Amount 2 for DM
1040-ES, Estimate Amount 3 for DM

OK Cancel
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18. Enter is due on, and enter a space. 

19. Choose Insert > Variable to open the Variables dialog. 

20. Click the Date option, and highlight the Date due for 1040-ES Estimate 2 (full text) variable in the 
Variable Name list.  

 
21. Click OK to insert the highlighted variable into the letter and enter a period after the variable. 

22. Use Steps 9 through 21 as a guide to enter text, date, and amount variables for 3rd and 4th quarter 
estimated tax payments.  

  

Variables ÿ X

Variables

Product:Federal

Amount Text Date Input screen Select field

Variable Name

Date appt - next (mm/dd/yy)
Date appt - prior (fulltext)
Date appt - prior (mm/dd/y)
Date due for1040-ES Estimate1 (fulltext)
Date due for 1040-ES Estimate 1 (mm/dd/y)
Date due for 1040-ES Estimate 2 (full text)
Date due for1040-ES Estimate 2 (mm/dd/yy)
Date due for 1040-ES Estimate 3 (full text)
Date due for 1040-ES Estimate 3 (mm/dd/yy)
Date due for1040-ES Estimate 4 (full text)
Date due for 1040-ES Estimate 4 (mm/dd/yy)

OK Cancel
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23. Edit other text in the letter as appropriate. 

 
24. Choose Document > Save, and then choose Document > Exit to return to Data Mining. 

Notice that the Estimate Reminder 4 Quarters letter displays in the list of letters that are available to 
print. 

[US: Label name]
[US: 1040, Address][US: 1040, Apartment number]
[US: 1040, City]. [US: 1040, State postal code][US:1040, Zip code]
[US: 1040, Foreign province or county] [US: 1040,Foreign postal code]
[US: 1040, Foreign country]

Dear [US: 1040, Sahutation]:

{Begin If: US: Form 1040-ES check - 1st quarter estimate}
FederalEstimate

Your first [US: Tax year - next] federal estimated tax payment of $[US: 1040-ES, Estimate
Amount 1 for DM] is due on [US: Date due for 1040-ES Estimate 1 (full text)].

Your second [US: Tax year - next] federal estimated tax payment of $[US: 1040-ES, Estimate
Amoumt 2 for DM] is due on [US: Date due for 1040-ES Estimate 2 (full text)].

Your third [US: Tax year - next] federal estimated tax payment of $[US: 1040-ES, Estimate
Amount 3 for DM] is due on [US: Date due for 1040-ES Estimate 3 (full text)].

Your fouth [US: Tax year - next] federal estimated tax payment of $[US: 1040-ES, Estimate
Amount 4 for DM] is due on [US: Date due for 1040-ES Estimate 4 (full text)]

You may use any of the following options to make the federal estimated tax payment:

Check - Make the check payable to the United States Treasury. Write your social security

address before]

Credit or Debit Card - Click on Credit or Debit Card at www.irs.gov/e-pay for the list of
IRS e-pay service providers and associated convenience fees. You may be able to deduct
convenience fees paid on next year's taxes so be sure to store the amount with your [US: Tax
year - next] tax information.

Electronic funds transfer or phone - Enroll in the Electronic Federal Tax Payment System?
(EFTPS) to pay electronically or via phone. There is no charge for using EFTPS. Contact
EFTPS for payment information by callng 1-800-555-4477 (Customer Service) or accessing
www.eftps.gov.

{End If: US: Form 1040-ES check - 1st quarter estimate}
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Identifying sole proprietors who pay employee health 
benefits or file Form 8941 
Sole proprietors who are paying employee benefits or filing Form 8941 are almost certain to benefit from 
tax savings under the Credit for Small Employer Health Insurance Premiums (Form 8941). But to continue 
to benefit from this credit, they will need to participate in an insurance exchange, and they may want to 
start investigating such exchanges now. 

Your clients are likely to appreciate a proactive call from you about this change, and it also provides you 
with a good opportunity to offer them additional services. You can use Data Mining to quickly identify 
these clients and to find their actual Schedule C net profits. Here's how: 

1. In UltraTax CS, choose Utilities > Data Mining.  

2. Select the 1040 Individual database if it is not already selected, then click Continue (Step 2).  

3. Click the Add/Modify Searches button.  

4. Click Add.  

5. Enter Clients claiming or eligible for Form 8941 in the Search name field.  

6. With the Form option marked, scroll through the list, highlight Form 8941 [Prepared], and click Select.  

7. Click the Input screen field option and click the Add/Modify button.  

8. In the Add/Modify Search Criteria dialog, click the Add button.  

9. In the Input Screen Field Selection dialog, navigate to the Business folder and click the C-2 tab.  

10. Click the statement “S” button for the Employee benefits field. 
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11. Click the Amount field, then click Select.  

12. In the Add/Modify Search Criteria dialog, select Any Keyed Data from the Operator drop-down list and 
click Enter.  

13. Click Done.  

14. With the Input screen field option still selected, highlight US: C-2, Employee benefits: Amount 
contains any keyed data and click Select. 

 
15. Click the Edit Formula button, then click the OR option.  

16. Click Done to finish editing the formula, click Done a second time to finish defining the custom search, 
and click Done a third time to close the list of searches.  

17. The Print Selection and Client Search dialog displays and automatically selects the new search. At 
this point, you need to decide whether to: 

 Generate a letter for each impacted client.  

 Generate a report listing each impacted client.  

 Generate both.  

18. In the Print selection group box, expand the drop-down list to choose Reports or Letters and to select 
the appropriate items to print from either category. If you simply want to generate a list of impacted 
clients, the CS Client Return Summary, CS Client Contact Information, or 1040 Client List w/Invoices 
report should suffice.  

19. After selecting the appropriate output, click Continue. Data Mining will determine which clients fit the 
criteria and will provide you with the opportunity to print any selected output items.  

Select Search Criteria

Search name:Clients claiming or eligible for Form 8941

Criteria selection
Product:Federal

 Form Calculated yalueInput screen field Return type Client status

US: Bank, Routing transit number - Prmy contains any keyed dataForm 8941 [Prepared]
US: Bank, Type of account - Prmy = 1 or 2 US: C-2, Employee benefits: Amount contains any keyed data
US: C, Non-1099-K receipts or sales contains any keyed data
US: C, Principal business contains any keyed data
US: C, Processes farm commodity checked
US: C-2, Employee benefits: Amount contains any keyed data

Add/Modif.... Select Remove

Selected criteria
Form 8941 [Prepared] Edit Formula.

OR US: C-2, Employee benefits: Amount contains any keyed data

Did you know... Done Cancel
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