Error: File cannot be accessed by the system when you export from Accounts Production Advanced

Scenario

You may get the following error message when you export a trial balance from Accounts Production Advanced as a Microsoft Excel file.
Error message
The file cannot be accessed by the system.

Cause

The likely cause is a failure of your Microsoft Windows operating system to access Excel files. This might happen after your firm re-installs or updates Microsoft Office, or when there's a problem with your firm's data storage.

Solution

  1. Check that Microsoft Excel opens and functions correctly.
  2. If Excel doesn't function correctly, ask your firm's IT professional to fix the problem.
  3. Find the location of the
    Excel.exe
    file on your computer and make a note of it.
  4. Run Windows Registry Editor as administrator.
  5. If the
    Computer\HKEY_LOCAL MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\excel.exe
    key is present:
    1. Select this key.
    2. Make sure the file path in the Data column of the
      (Default)
      setting is correct.
     Windows Registry Editor. In the tree diagram of Registry keys in the first pane, the Computer\HKEY_LOCALMACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\excel.exe Registry key is selected. The second pane shows the values within the excel.exe Registry key.  The file path for excel.exe is shown in the Data column for the valled called (Default).
  6. If the
    Computer\HKEY_CURRENT USER\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\excel.exe
    key is present:
    1. Select this key.
    2. Make sure the file path in the Data column of the
      (Default)
      setting is correct.
  7. Close Microsoft Windows Registry.
  8. Restart the computer and re-export the trial balance.