Error: template file not found or directory not created in Practice Management

Scenario

You may get the following error message when you try to run a report in Practice Management.
Error message
Report(s) not generated, or upgraded, because the 'template file could not be found' or 'the directory....could not be created' or access denied

Cause

The error message may be caused by a switch to another server or another PC, or it could be that you don't have permission to access the specified location.

Solution part one: check the location

  1. In Practice Management, select
    File
    , then
    Log on as Administrator
    .
  2. Select Tools, Options, then General Options.
  3. Select the
    Defaults
    tab
  4. Check the
    Reports Settings Templates Location
    .
  5. Ask colleagues at your firm if they can run reports and if they get the same error.
  6. If your colleagues can run reports, it could mean that you do not have the permissions required to access the specified reports location. Contact your system administrator. Check that there are no differences in the Mapping on the affected PCs to the templates location.
  7. If your colleagues cannot run reports, check the file path shown on the
    Defaults
    tab is accessible to all users (for example, check that the correct Master machine/server location is shown if you have a Server/Peer to Peer setup).

Solution part two: update file path after migration to a new server

If you need to change the filepath because you've migrated to a new server, follow the instructions as this explains how to back up the reports in your original environment and how to restore them in the new environment.
  1. If you get an error message saying permission has been denied, open Windows Explorer and go to the default location set (as shown in the error message).
  2. Select the
    Security
    tab.
  3. Right-click to review the
    Properties
    .
    note
    • The user needs to have Full Control to carry out the task of importing the reports.
    • If the location is on a central server, you may need to go onto the server as Administrator to edit permissions.
    • You may need to consult your local system administrator if security measures and permissions are in place to prevent users from changing the settings of folders on the server
  4. When the file path set in the program is correct and you have the required permission, you should be able to import and run the reports as required.
important
We recommend that you back up your reports package regularly. If you have bespoke templates, a backup of your reports package is essential, because the reports are not backed up when you back up the Practice Management database.