Upload CT600 from Digita error: A contact name must be provided

Scenario

You may see the following error message when attempting to upload a CT600 for a company client from Digita Corporation Tax to Onvio.
Error message
Failed to add document to Onvio Documents
A contact name must be provided when performing the first document upload to Onvio Documents. Ideally your contact should have an email address and National Insurance number/UTR in order to uniquely identify them.

Causes

The likely cause of this error message is that a Declaration name hasn't been set up for the client in Digita Corporation Tax.

Solution

  1. Open Digita Corporation Tax.
  2. Double-click the client's name.
  3. In the Client Details section, select the
    Company Details
    link.
  4. Select the Other Information tab.
  5. In the Declaration section, select the Name button.
  6. In the Select Person dialog, select the person who is authorised to make the Declaration (if that person is not already displayed, select the Add button to add their details).
  7. Select the Edit button.
  8. In the Edit Person dialog, check that the NI number/Tax Reference are correct, then select the OK button.
  9. With that person still selected in the list of the Select Person dialog, select the OK button.
  10. Select the position for the person authorised to make the Declaration from the
    Post
    drop-down list (Chairman, Director, or Secretary).
  11. Select the OK button.