Pass-thru e-Form RS link troubleshooting

Condition

You're using Checkpoint and the pass-thru link to open e-Form RS, but it is not opening or you get prompted to save the e-Form RS application instead of opening it.

Cause

This typically happens when your system requirements are out of date.

Solution

If you get the System Update Required message when trying to install or run e-Form RS, your machine has an old version of .Net Framework. The latest version of .NET Framework can be installed from Microsoft.com. If this doesn't fix the issue, you're getting a different error, or e-Form RS isn't opening, try installing a ClickOnce add-on in your browser:
  1. Close the error message.
  2. If you're using Google Chrome, install the Cegid PeopleNet ClickOnce add-in.
  3. If you're using Microsoft Edge, enable Click Once support.
  4. If you're using Mozilla Firefox, install the Breez ClickOnce add-in.
  5. Once you've installed or enabled the relevant item, go back to Checkpoint and re-launch e-Form RS.