Error: WorkFlow Tools has fired an exception

Scenario

You may see the following error message when you work in Microsoft Excel, Outlook, or Word.
Error message
'WorkFlow Tools' has fired an exception. Click the 'Details' button to see the detailed information about the error.

Cause

This error could be caused by either of the following:
  • A third-party add-in conflicts with the Thomson Reuters WorkFlow Tools add-in component of the Client Add-in.
  • In Word or Excel, a file in the Recent documents list may be corrupt.

Solutions

Solution 1: Third party add-ins conflict with the Thomson Reuters WorkFlow Tools add-in

Follow these steps to temporarily turn off the add-ins that may be causing the conflicts.
  1. In Microsoft Word or Excel, close all but one session of the application that had the error.
  2. Select
    File
    , then
    Options
    .
  3. Select
    Add-ins
    .
  4. In the
    Manage
    field, select
    COM Add-ins
    , then
    Go
    .
  5. In the COM Add-ins window, clear all checkboxes
    except
    for the following (if present):
    • Excel
      • EngagementManagerExcelAddIn
      • CS.Accounting.OfficeIntegration.ExcelVstoAddin
      • PPCMenu
      • Ppc OBPA
      • PPCExcel12
      • PPCExcel12Repurpose
      • Thomson Reuters WorkFlow Tools
    • Outlook
      • GFRCPOutlookIntegration
      • GFRRedemption.Addin
      • Thomson Reuters WorkFlow Tools
    • Word
      • EngagementManagerWordAddIn
      • Ppc OBPA
      • PPC Word Menu
      • PPCSecurityDSRWord
      • PPCWord12
      • PPCWord12Repurpose
      • Thomson Reuters WorkFlow Tools
  6. Select
    OK
    .
  7. In Excel, select
    File
    ,
    Options
    , then
    Add-ins
    . In the
    Manage
    field, select
    Excel Add-ins
    , then
    Go
    .
  8. Clear all items
    except
    for the following (if present):
    • EngagementManager.ExcelAutomationFns
    • Csaaddin
    • Cs.Accounting.Excel.Automation
    • Obetexcelvbacommon
  9. Select
    OK
    .
  10. Close and reopen the Office applications and make sure the changes were saved.
  11. Check the functionality of the Thomson Reuters WorkFlow Tools add-in.
  12. Turn on the third-party add-ins, one at a time, until you determine which add-in is causing the conflict.

Solution 2: Uninstall and reinstall the Client Add-in

Complete a full uninstall and reinstall of the add-in to replace any missing or damaged files.

Solution 3: Repair Microsoft .NET Framework

  1. Select
    Windows Start
    , then
    Control Panel
    .
  2. Select
    Programs and Features
    .
  3. In the list of installed programs, find
    Microsoft .NET Framework
    and select
    Repair
    .
  4. If prompted, restart your computer.

Solution 4: Corrupt recent document

If this error occurs as soon as you open Word or Excel, follow these steps to determine if a recently-accessed document is corrupt.
  1. In the WorkFlow Tools error window, select
    Details
    .
  2. If any of the lines contain
    RecentAccessedDocument
    , it means that a recently accessed document is corrupt.
If a file in the Recent documents is corrupt, follow these steps to rename it:
  1. Close all sessions of Word and Excel.
  2. In Windows Explorer, go to
    C:\Users\<username>\AppData\Roaming\GoFileRoom\GFROffice
    .
  3. Rename the applicable XML file to a temporary name:
    • Excel:
      recentdocs_excel.xml
    • Word:
      recentdocs_word.xml
  4. Reopen the affected application. The add-in should now work properly.

Solution 5: Uninstall and reinstall the Client Add-in

Complete a full uninstall and reinstall of the add-in to replace any missing or damaged files.

Solution 6: Repair Microsoft Office

  1. Select
    Windows Start
    , then
    Control Panel
    .
  2. Select
    Programs and Features
    .
  3. In the list of installed programs, find
    Microsoft Office
    and select
    Change
    .
  4. If prompted, select
    Online repair
    .
  5. If prompted, restart your computer.
  6. Make sure that the Office applications open successfully outside of GoFileRoom.

error-icon

error-close