NEGeneral-0001 e-file error

Error

A return has already been filed for this Nebraska State Id for this tax period end date.

Cause

The e-file database shows this ID has already been used on an accepted return.

Solution

  1. In the Organizer, go to
    States
    .
  2. Select
    Nebraska
    and then
    General Information
    .
  3. Verify that you've entered a valid State ID.
  4. If the ID was already entered, contact the state to verify/obtain the correct ID number for this return.
note
If you don't have a record of your Nebraska State ID, the taxpayer or representative with a POA on file with the Department may contact our Taxpayer’s Assistance office at 800-742-7474.

error-icon

Triva isn't available right now.

Check out the support page for our phone number and hours

error-close