Unable to open this new binder...

Scenario

You may get this error when trying to open a return.
Error message
Unable to open this new binder because all purchased binders have been used. No additional new binders may be opened. Please see your Administrator.

Cause

This happens when all binders have been used or are expired.

Solution

To review your binder balance for your account:
  1. Go to
    Help
    ,
    Account Info
    .
  2. Select the year, and then
    Display
    .
  3. Find the
    Binders Purchased
    table and review what's purchased, used, and expiration date.
Chat now

error-icon

Triva isn't available right now.

Check out the support page for our phone number and hours

error-close