SQL exception error: Login failed for user 'CreativeSolutions DatabaseOwner'

Scenario

You may get the following error message when you attempt to open your CS Professional Suite application.
Error message
Error when opening <application name>, System.Data.SqlClient.SqlException: Login failed for user 'CreativeSolutions<application name>DatabaseOwner'. Reason: Not associated with a trusted SQL Server connection.

Cause

Your CS Professional Suite application requires the SQL Server to be configured to allow both Windows and SQL Authentication.

Solutions

Complete these solutions in the following order:
Rerun step 2 of the installation
  1. Download and execute the latest installation file from cs.thomsonreuters.com.
  2. On the
    Installation Steps
    screen wtih three steps, select
    Step 2
    to start it.
  3. On the next screen, select
    Use the CREATIVESOLUTION instance of Microsoft SQL Server
    .
  4. Complete the installation by following the prompts to the last screen, then select
    Finish
    .
Change the security settings in SQL Server Management Studio
  1. Open
    SQL Server Management Studio
    on the SQL server.
  2. Right-click the server.
  3. Select
    Properties.
  4. Select
    Security
    .
  5. Change the
    Security
    settings to allow for both
    Windows & SQL Authentication
Check the size of the database files (mdf and ldf)
  1. On the SQL server, go to the data directory for the SQL files.
  2. If the combined size of these two files. is causing the database to be at or over the limit for SQL express (10GB for SQL Express 2014), you could receive this error
  3. If the mdf is nearing the SQL express limit, your firm needs to upgrade SQL.
  4. If the log.ldf file causes the database to near the SQL express limit, stop SQL on the SQL server, remove the log.ldf file from the data folder and then start SQL.  A new log.ldf file will be created and will be very minimal in size.
  5. Open your CS Professional Suite application.