The PPC Library.xml file does not exist error

Condition

When launching Checkpoint Tools you get, “The file below does not exist. C:\Program Files\Common Files\PPC\Templates\xxxxxxxx\PPC Library.xml Please re-install product xxxx and retry.”

Cause

This issue can happen for a few reasons reasons:
  • The template file has been moved, renamed or deleted.
  • An admin install was performed from a 32-bit machine and then tried to install it to a 64-bit machine.  Because the admin install was ran from a 32-bit system, the install path pointed to C:\Program Files.  When this .msi file was used to install to the 64-bit system, it installed to the C:\Program Files location instead of the C:\Program Files (x86) location.
  • If the CP tools titles have been uninstalled and the user is receiving the error then, Run REGEDIT and browse to HKLM\Software\Wow6432Node\PPC\OfficeBasedPracticeAids\(product acronym)\(year version)\InstallDefaults. and delete the folder in the error message.

Remedy

Check the following:
  1. To resolve the issue if the template folder has been moved, renamed or deleted:
    1. Run a repair on the title in question. Note: that you may have to reinstall the application if the repair does not correct the issue.
  2. To resolve the issue if installed to a different directory, perform the following steps:
    1. Run REGEDIT and browse to HKLM\Software\Wow6432Node\PPC\OfficeBasedPracticeAids\(product acronym)\(year version)\InstallDefaults.
    2. Change the “AppPath2” registry entry to point to C:\Program Files (x86)\Common Files\PPC\Templates\.....