Error: Class csi_core_library::Registry::RegLiteException::Failed to Attach

Scenario

You may see this error when you open FileCabinet CS.
Class csi_core_library::Registry::RegLiteException::Failed to attach

Cause

This error is caused by improper permissions to the registry, a missing or incorrect AppPath registry key, or strict User Account Control (UAC) settings.

Solutions

We recommend that you work with your qualified IT professional to make registry changes, as problems with the registry can cause serious problems with the operating system. Also, we recommend that you create a backup of your registry before making any changes to it.
Run as administrator
Use the following steps to open the setup file or application as an administrator.
  1. Right-click on the
    setup.exe
    or FileCabinet CS icon and choose
    Run as administrator
    .
Permissions to the registry
Use the following steps to verify that you have appropriate permissions to access and update the registry.
  1. Open the Registry editor
  2. When you are prompted to allow the app to make changes, select
    Yes
    .
  3. In the registry tree, navigate to
    HKEY_CURRENT_USER\Software
    and expand the list.
  4. Right-click
    Classes
    and choose
    Permissions
    .
  5. Verify that the current username that you used to log in has full control for this folder.
Missing or incorrect registry keys
Use the following steps to verify that you have the correct registry entries.
  1. Open the Registry editor
  2. When you are prompted to allow the app to make changes to your device, select
    Yes
    .
  3. In the registry tree, navigate to
    HKEY_LOCAL_MACHINE\Software\Creative Solutions\CSI Tools\Installation
    .
    (For a 64-bit machine, navigate to
    HKEY_LOCAL_MACHINE\Software\Wow6432Node\Creative Solutions\CSI Tools\Installation
    .)
  4. Verify that the
    AppPath
    key is there and that the path in the
    Data
    column is correct.
    The correct path is listed in the
    csitools.txt
    file in the
    X:\WinCSI\Tools
    (where X represents the network drive where FileCabinet CS is installed).
    If the key is there but the path is incorrect, double-click the AppPath file and update the path in the
    Value data
    field.
    If the key or the folders are missing, create them as follows.
    1. Right-click the
      Creative Solutions
      folder and choose
      New > Key
      , and then rename the new key to
      CSI Tools
      .
    2. Right-click the new
      CSI Tools
      key and choose
      New > Key
      , and then rename the new key to
      Installation
      .
    3. Right-click the new
      Installation
      key and choose
      New > String Value
      , and then rename the new key to
      AppPath
      .
    4. Double-click the new AppPath key and in the
      Value Data
      field, enter the correct path (from the
      csitools.txt
      file).
User Account Control (UAC) settings
As defined by Microsoft, User Account Control is a feature in Windows that informs you when a program makes a change that requires administrator-level permissions. Enabling UAC may interfere with the installation, performance, and functionality of FileCabinet CS; therefore, we recommend disabling UAC on each workstation as follows.
  1. Open the Control Panel
  2. Select
    User Accounts
    .
  3. Select the
    Change User Account Control Settings
    link.
  4. Move the slider to
    Never notify
    , and then select
    OK
    .
  5. Restart the computer.
note
Your firm's network or security policy may not allow you to disable User Account Control. We recommend installing all CS Professional Suite applications using the
Run as administrator
option. If UAC is enabled and you encounter any issues while installing or using any CS Professional Suite application, you may need to disable UAC as a troubleshooting step. For further assistance, consult your qualified IT professional.