Error: Not enough storage is available

Scenario

You may see this error when you embed a supported file into FileCabinet CS.
Not enough storage is available. Occurred while trying to embed this object as...

Cause

The document that you are attempting to embed is possibly corrupt.

Solutions

Create a new document
  1. Save the document under a different name.
  2. Try to embed the renamed document.
  3. If you're still getting the error, copy the contents of the document into a new document and then save it.
  4. Embed the new document with the copied contents.
Re-embed a new document
Use these steps if you've already embedded the document in FileCabinet CS and it worked previously.
  1. Choose
    File
    Send To
    File
    .
  2. Select the location where you want to save the document (e.g., your workstation's desktop).
  3. Browse to the location where you saved the document and open it.
  4. If you receive any errors, go past them.
  5. Save the file with a different name.
  6. Embed the document with the new name into FileCabinet CS.
Check for invisible content
If you are still getting the error and the embedded document is a Microsoft Office file, it is possible that the file contains invisible content. Sometimes Microsoft Office files that were exported from other applications will have invisible EMF images that Office cannot handle. To remove this invisible content, use the following steps.
  1. Open the file in its native application, outside of FileCabinet CS.
  2. Choose
    File
    Check for Issues
    Inspect document
    .
  3. Mark the
    Invisible Content
    checkbox and then select
    Inspect
    .
  4. If the results find invisible content, select
    Remove All
    for that category.
  5. Save the file, and embed it into FileCabinet CS again.
  6. Verify that the document opens and closes without displaying an error message.