Error: Documents opened in GoFileRoom in view mode open outside the browser window

Scenario

When you open Word, Excel, or PDF files in GoFileRoom in view mode, the files should open in an Internet browser window with GoFileRoom menu options.
Occasionally, the files will open in their native application outside of the browser and the GoFileRoom options will open separately in an blank browser window. You may also notice that the open document displays the ten-digit GoFileRoom document ID rather than the document index information.

Cause

There are settings on each computer that control this behavior. If these settings are not correct, the files will open in their native application outside of the browser, and the GoFileRoom options will open separately in an otherwise blank browser window.

Solution

Follow these steps for the type of file you're opening.

Microsoft Word or Excel

Follow these steps to update the following list of registry values.
important
  • Thomson Reuters recommends that you have a qualified technician make the registry changes, as problems with the registry can cause serious problems with the operating system. We also recommend that you back up the registry before making any changes to it.
  • Microsoft provides Windows registry information for advanced users about how to edit and back it up.
  • Applying updates to Windows, Microsoft Edge, or Microsoft Office may cause settings in the registry to be removed or changed. To prevent this issue from occurring, your firm's IT professional may want to consider using a group policy to apply these settings, or creating a REG file to restore these settings after updates are applied. Microsoft provides information about how to modify registry values with a REG file.
  1. Sign out of GoFileRoom, then close your internet browser, Excel, and Word.
  2. Enter
    Regedit
    in the Windows search bar and select
    Registry Editor
    .
    note
    If prompted by User Account Control to allow this program to make changes, select
    Yes
    .
  3. In the Registry Editor, go to
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.Document.8]
    .
  4. Right-click
    BrowserFlags
    and select
    Modify
    .
    note
    If the BrowserFlags item doesn't exist after the original registry has been backed up or exported, right-click in the right pane and select
    New
    , then
    DWORD (32-bit) value
    , and name the item
    BrowserFlags
    .
  5. Select
    Hexadecimal
    , enter
    80000024
    in the
    Value data
    field, and select
    OK
    .
  6. Follow steps 3-5 for each of the following registry locations and their corresponding BrowserFlags value data:
    • [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.RTF.8], 80000024
    • [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.Document.12], 80000024
    • [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.DocumentMacroEnabled.12], 80000024
    • [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.8], 80000A00
    • [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.12], 80000A00
    • [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.SheetMacroEnabled.12], 80000A00
    • [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.SheetBinaryMacroEnabled.12], 80000A00

Adobe Acrobat PDFs

The Adobe Acrobat add-on for Microsoft Edge may be disabled. Follow these steps to edit the settings to display PDFs in a browser.

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