Error: Contact cannot be deleted because it is currently in use by Schedule Item contact

Scenario

You may get the following error message when trying to delete a contact.
Error message
Contact cannot be deleted because it is currently in use by Schedule Item contact.

Cause

This happens because the contact has items in
Documents
Communications
(active, completed, or canceled).

Solution

important
Deleting a contact removes all history. Often, it's better to set the contact to Inactive and turn off Onvio Access to stop billing while keeping history.
If you must delete:
  1. Find and delete related Communications.
    1. Go to
      Documents
      Communications
      .
    2. Search the contact’s exact name (try prior names or even just the full first name).
    3. Include all statuses: active, completed, canceled.
  2. Remove the Communications.
    1. When looking for items assigned to the contact, focus on the Recipient column.
    2. Manually delete each related item.
  3. Try deleting the contact again.
  4. If you get the error again try steps 1-3 again, if you still can't delete, contact support for assistance.
tip
  • The
    Communications
    tab doesn’t update when a name changes in Onvio. If nothing shows, search previous names.
  • The Communications grid doesn’t do partial matches. Use the exact name (for example, “Jonathan,” not “Jon”).
  • The error lists 1 blocker, but there may be several.
Internal use only
Still stuck?
  • Contact an Onvio Consultant.
  • Submit an ADO to Area Path Onvio_Global_Support\Onvio Center. Include details and screenshots of your Communications filters and searches.
  • If the contact was added prior to 2022 there is a greater chance that intervention is needed via an ADO, even if all Communications are deleted.