Error: Outlook failed due to fatal error

Scenario

You may get the following error message when you open Practice CS or use a feature that interfaces with Microsoft Outlook. For example, mail, calendars, or tasks.
Error message
Outlook failed due to fatal error: Outlook dependent files have been moved on your machine.

Cause

Practice CS is not able to integrate with Microsoft Outlook.

Solution 1: close and reopen

  1. Sign out of and close Practice CS.
  2. Close Microsoft Outlook.
  3. Reopen Microsoft Outlook.
  4. Make sure it works and you can send or receive emails and access the Calendar. 
  5. Open Practice CS.

Solution 2: disable Outlook integration with Practice CS

  1. Open your Start menu and search for the
    Run
    app.
  2. Open
    Run
    and paste
    C:\ProgramData\Creative Solutions\Practice CS
    in the
    Open
    field.
  3. Select
    OK
    .
  4. Right-click the
    LocalInstallation.ini
    file, select
    Open with
    , and choose
    Notepad
  5. In the Notepad file, add a new line in the
    [appSettings]
    section and paste this code in the empty line:
    outlookdisable=true
    .
  6. Select
    File
    , then
    Save
    .

Solution 3: for Virtual Office CS or SaaS only

Follow these steps if you use Virtual Office CS or SaaS.
  1. Outlook must be configured in Virtual Office CS/SaaS.
    • You must give each NetStaff user access to Microsoft Outlook.
    • You must have an email account set up in Outlook for each NetStaff user. You can use either a POP3 account or Microsoft Exchange.
  2. Outlook must be opened before Practice CS and remain open while working in Practice CS.
  3. To use calendars, you must have Microsoft Exchange enabled.
  1. Close both Practice CS and Microsoft Outlook.
  2. Use the Log Off Applications utility to clear any hung sessions.
  3. Open Microsoft Outlook.
  4. Open Practice CS. If it works, keep Outlook open while you work. If Outlook fails while opening Practice CS, contact Support.

Solution 2: for non-Virtual Office CS or SaaS installations

Follow the steps here if you have a local installation of Practice CS. 
  1. Outlook must be opened before Practice CS, and it must remain open while working in Practice CS.
  2. In order to use calendars, you need to have Microsoft Exchange with access to a public folder in Outlook.Consult your IT professional or Exchange host to set up public folders in Outlook.
  3. Close both Practice CS and Microsoft Outlook.
  4. Open Microsoft Outlook. If Outlook is not functioning (i.e. you receive an error when opening it, you cannot send or receive emails, or you cannot access the calendar), contact your IT professional for assistance.
  5. Open Practice CS. If you receive the message that Outlook has failed while opening Practice CS, continue to the troubleshooting steps below.
  6. If you are able to get in to Practice CS without errors, leave Microsoft Outlook open while you work in Practice CS. If you continue to receive the "Outlook failed" error, continue to the troubleshooting steps below.
Run both Practice CS and Outlook as administrator. To run or install Microsoft Outlook as administrator, work with your firm's IT professional.
If you are not able to run or install Outlook as administrator, make sure Practice CS is not running as administrator:
  1. Right-click the Practice CS desktop icon and choose
    Properties
    .
  2. Open the Compatibility tab and clear the
    Run as administrator
    checkbox.
  1. Go to the
    Control Panel
    and select
    Programs
    , then
    Programs and Features
    .
  2. Right-click Practice CS.
  3. Choose
    Repair
    . If Repair is not an option, choose
    Change
    , then
    Repair
    in the setup window that opens.
Questions or problems with repairing Microsoft Office should be directed to your IT professional.
  1. Go to the
    Control Panel
    and select
    Programs
    , then
    Programs and Features
    .
  2. Right-click Microsoft Office.
  3. Choose
    Repair
    . If Repair is not an option, choose
    Change
    , then
    Repair
    in the setup window that opens.
Questions or problems with reinstalling Microsoft Office should be directed to your IT professional.
  1. Go to the
    Control Panel
    and select
    Programs
    , then
    Programs and Features
    .
  2. Right-click
    Practice CS
    and choose
    Uninstall
    .
  3. Uninstall Microsoft Office from the workstation. This must be completed by your firm's IT professional.
  4. Restart the workstation.
  5. Install Microsoft Office 32-bit. This version must be 32-bit and it must be completed by your firm's IT professional.
  6. Browse to 
    X:\WinCSI\Practice CS\DESKTOP
    where X is the mapped network drive or server name where Practice CS is installed and run
    Setup.exe
    .