Error: Practice CS was able to connect to your database server

Error message

Practice CS was able to connect to your database server, but could not find an available Practice CS database to connect to. You will not be able to access Practice CS until a Practice CS database is available.

Causes

  • All Practice CS databases may have been moved or deleted.
  • The computer can't access the SQL Server on your network.
  • If you enabled Remote Entry you may not be connected to your network. 

Solution 2: network connection

  1. Make sure your workstation is connected to your network.
  2. Open Practice CS.

Solution 2: reinstall a Sample database

  1. On the server where Practice CS is installed, download the latest version of Practice CS from the My Product Downloads page of the website.
  2. Open the installation package and run Step 2 of the installation.
    1. If it will not allow you to reinstall Step 2 without first completing Step 1, install Step 1 to the same location as you originally installed Practice CS. This may cause a reboot of your server)
  3. Skip Step 3 of the installation.
  4. Open Practice CS.
Internal use only
note
For Virtual Office/SaaS firms, visit the Web Consultant.
If the firm's SQL database includes the firm ID in the database name but the firm currently has trial licenses shown, they will receive this error message. If the steps above don't resolve the issue, you can walk the user through the following steps as an alternative.
  1. Open SQL Server Management Studio.
  2. Expand the
    Security
    folder.
  3. Expand the
    Logins
    Folder.
  4. Right-click
    CreativeSolutionsPracticeCSDatabaseOwner
    and select
    Properties
    .
  5. Select the
    User Mappings
    page from the left side of the dialog.
  6. Mark the checkbox next to the database you're unable to open.
  7. Mark the db_owner checkbox in the Database role membership for: [database_name] section.
  8. Select
    OK
    .